{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-39528 in the wild and no public exploit code.","fix":"Upgrade prestashop/prestashop to 8.1.1 or later.","what":"CVE-2023-39528 is a medium-severity path traversal vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-39528 and fix it if it is affected.\n\nWhat it is: CVE-2023-39528 is a medium-severity path traversal vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-39528 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.1\n- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39528/ (Markdown: https://insights.sbomify.com/CVE-2023-39528/index.md)","id":"CVE-2023-39528","markdown":"https://insights.sbomify.com/CVE-2023-39528/index.md","name":"CVE-2023-39528","record":{"aliases":["GHSA-hpf4-v7v2-95p2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop e-commerce","requires_auth":"high_privilege","summary":"Attackers can read arbitrary files on the server via the displayAjaxEmailHTML method in PrestaShop, exposing sensitive data.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop","vendor":"prestashop"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, the `displayAjaxEmailHTML` method can be used to read any file on the server, potentially even outside of the project if the server is not correctly configured. Version 8.1.1 contains a patch for this issue. There are no known workarounds.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PrestaShop vulnerable to file reading through path traversal","id":"CVE-2023-39528","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"prestashop:prestashop","products":["prestashop:prestashop"],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"PrestaShop vulnerable to file deletion via attachment API","id":"CVE-2023-39529"},"packages":[{"ecosystem":"Packagist","fixed":["8.1.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-hpf4-v7v2-95p2"},{"ecosystem":"Packagist","fixed":["8.1.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-hpf4-v7v2-95p2"}],"prev":{"headline":"PrestaShop XSS vulnerability through Validate::isCleanHTML method","id":"CVE-2023-39527"},"products":["PrestaShop"],"published":"2023-08-07","related":[{"cvss_score":10,"headline":"PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using \"SQL Manager\"","id":"CVE-2023-30839","kev_date_added":null,"published":"2023-04-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-5791","kev_date_added":null,"published":"2008-12-31"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2024-41651","kev_date_added":null,"published":"2024-08-12"},{"cvss_score":9.8,"headline":"Remote code execution in prestashop","id":"CVE-2022-31181","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-3110","kev_date_added":null,"published":"2021-01-20"},{"cvss_score":9.8,"headline":"Blind SQL Injection in PrestaShop","id":"CVE-2020-15160","kev_date_added":null,"published":"2020-09-24"},{"cvss_score":9.8,"headline":"Privilege escalation in n/a","id":"CVE-2013-6295","kev_date_added":null,"published":"2020-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["PrestaShop"]},"summary":"Attackers can read arbitrary files on the server via the displayAjaxEmailHTML method in PrestaShop, exposing sensitive data.","url":"https://insights.sbomify.com/CVE-2023-39528/"}