CVE-2023-39531 Sentry vulnerable to incorrect credential validation on OAuth token requests
Attackers can retrieve valid access tokens for other users during OAuth exchange due to incorrect credential validation, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-39531?
CVE-2023-39531 is a medium-severity authentication bypass vulnerability in getsentry sentry, published on 9 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
Weakness: CWE-287
Which versions are affected by CVE-2023-39531?
3 open source packages ship an affected version, including sentry. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sentry PyPI | From 10.0.0 | 23.7.2 |
sentry PyPI | From 10.0.0 | 23.7.2 |
sentry PyPI | From 10.0.0 | 23.7.2 |
Products include Sentry Sentry.
How do I fix CVE-2023-39531?
Upgrade sentry to 23.7.2 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2023-39531 being exploited?
There is no known exploitation of CVE-2023-39531 in the wild and no public exploit code.
Other vulnerabilities in getsentry sentry
- CVE-2026-42354 Sentry: Improper authentication on SAML SSO process allows user identity linking
- CVE-2026-27197 Sentry: Improper Authentication on SAML SSO process allows user identity linking
- CVE-2021-47935 Sentry 8.2.0 Remote Code Execution via Pickle Deserialization
- CVE-2023-39349 Sentry vulnerable to privilege escalation via ApiTokensEndpoint
- CVE-2023-36826 Sentry vulnerable to improper authorization on debug and artifact file downloads
Sources
Also known as GHSA-hgj4-h2x3-rfx4, PYSEC-2026-1915.