{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-39531 in the wild and no public exploit code.","fix":"Upgrade sentry to 23.7.2 or later.","what":"CVE-2023-39531 is a medium-severity authentication bypass vulnerability in getsentry sentry, published on 9 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-39531 and fix it if it is affected.\n\nWhat it is: CVE-2023-39531 is a medium-severity authentication bypass vulnerability in getsentry sentry, published on 9 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-39531 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 10.0.0; fixed in 23.7.2\n- sentry (PyPI): affected from 10.0.0; fixed in 23.7.2\n- sentry (PyPI): affected from 10.0.0; fixed in 23.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39531/ (Markdown: https://insights.sbomify.com/CVE-2023-39531/index.md)","id":"CVE-2023-39531","markdown":"https://insights.sbomify.com/CVE-2023-39531/index.md","name":"CVE-2023-39531","record":{"aliases":["GHSA-hgj4-h2x3-rfx4","PYSEC-2026-1915"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry error tracking","requires_auth":"low_privilege","summary":"Attackers can retrieve valid access tokens for other users during OAuth exchange due to incorrect credential validation, requiring an upgrade to fix.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry vulnerable to incorrect credential validation on OAuth token requests","id":"CVE-2023-39531","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"SES's dynamic import and spread operator provides possible path to arbitrary exfiltration and execution","id":"CVE-2023-39532"},"packages":[{"ecosystem":"PyPI","fixed":["23.7.2"],"introduced":["10.0.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-hgj4-h2x3-rfx4"},{"ecosystem":"PyPI","fixed":["23.7.2"],"introduced":["10.0.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-hgj4-h2x3-rfx4"},{"ecosystem":"PyPI","fixed":["23.7.2"],"introduced":["10.0.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2026-1915"}],"prev":{"headline":"PrestaShop vulnerable to file deletion via CustomerMessage","id":"CVE-2023-39530"},"products":["sentry"],"published":"2023-08-09","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.1,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","kev_date_added":null,"published":"2026-02-21"},{"cvss_score":8.7,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","kev_date_added":null,"published":"2026-05-10"},{"cvss_score":8.1,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":7.7,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":7.3,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","kev_date_added":null,"published":"2024-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["getsentry"]},"summary":"Attackers can retrieve valid access tokens for other users during OAuth exchange due to incorrect credential validation, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-39531/"}