# CVE-2023-39531: Sentry vulnerable to incorrect credential validation on OAuth token requests

> Attackers can retrieve valid access tokens for other users during OAuth exchange due to incorrect credential validation, requiring an upgrade to fix.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Aug 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-hgj4-h2x3-rfx4, PYSEC-2026-1915

## What is CVE-2023-39531?

CVE-2023-39531 is a medium-severity authentication bypass vulnerability in getsentry sentry, published on 9 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-39531?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 10.0.0 | 23.7.2 |
| `sentry` | PyPI | From 10.0.0 | 23.7.2 |
| `sentry` | PyPI | From 10.0.0 | 23.7.2 |

Products: Sentry Sentry.

## How do I fix CVE-2023-39531?

Upgrade sentry to 23.7.2 or later.

## Is CVE-2023-39531 being exploited?

There is no known exploitation of CVE-2023-39531 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39531 and fix it if it is affected.

What it is: CVE-2023-39531 is a medium-severity authentication bypass vulnerability in getsentry sentry, published on 9 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-39531 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 10.0.0; fixed in 23.7.2
- sentry (PyPI): affected from 10.0.0; fixed in 23.7.2
- sentry (PyPI): affected from 10.0.0; fixed in 23.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39531/ (Markdown: https://insights.sbomify.com/CVE-2023-39531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39531
- OSV: https://osv.dev/vulnerability/CVE-2023-39531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39531/
Summaries are generated and may contain mistakes; the official description above is the record.
