CVE-2023-39532 SES's dynamic import and spread operator provides possible path to arbitrary exfiltration and execution

Critical 9.8 Published Updated

Attackers can bypass SES sandbox confinement via dynamic import to execute arbitrary code or exfiltrate data in Node.js or web environments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-39532?

CVE-2023-39532 is a critical code injection vulnerability in endojs endo, published on 8 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SES is a JavaScript environment that allows safe execution of arbitrary programs in Compartments. In version 0.18.0 prior to 0.18.7, 0.17.0 prior to 0.17.1, 0.16.0 prior to 0.16.1, 0.15.0 prior to 0.15.24, 0.14.0 prior to 0.14.5, an 0.13.0 prior to 0.13.5, there is a hole in the confinement of guest applications under SES that may manifest as either the ability to exfiltrate information or execute arbitrary code depending on the configuration and implementation of the surrounding host.

Guest program running inside a Compartment with as few as no endowments can gain access to the surrounding host’s dynamic import by using dynamic import after the spread operator, like `{...import(arbitraryModuleSpecifier)}`.

On the web or in web extensions, a Content-Security-Policy following ordinary best practices likely mitigates both the risk of exfiltration and execution of arbitrary code, at least limiting the modules that the attacker can import to those that are already part of the application. However, without a Content-Security-Policy, dynamic import can be used to issue HTTP requests for either communication through the URL or for the execution of code reachable from that origin.

Within an XS worker, an attacker can use the host’s module system to the extent that the host has been configured. This typically only allows access to module code on the host’s file system and is of limited use to an attacker.

Within Node.js, the attacker gains access to Node.js’s module system. Importing the powerful builtins is not useful except insofar as there are side-effects and tempered because dynamic import returns a promise. Spreading a promise into an object renders the promises useless. However, Node.js allows importing data URLs, so this is a clear path to arbitrary execution.

Versions 0.18.7, 0.17.1, 0.16.1, 0.15.24, 0.14.5, and 0.13.5 contain a patch for this issue. Some workarounds are available. On the web, providing a suitably constrained Content-Security-Policy mitigates most of the threat. With XS, building a binary that lacks the ability to load modules at runtime mitigates the entirety of the threat. That will look like an implementation of `fxFindModule` in a file like `xsPlatform.c` that calls `fxRejectModuleFile`.

Weakness: CWE-20

Which versions are affected by CVE-2023-39532?

12 open source packages ship an affected version, including ses. It affects 1 product.

PackageAffectedFixed in
ses npmFrom 0.13.00.13.5
ses npmFrom 0.13.00.13.5
ses npmFrom 0.14.00.14.5
ses npmFrom 0.14.00.14.5
ses npmFrom 0.15.00.15.24
ses npmFrom 0.15.00.15.24
6 more packages
ses npmFrom 0.16.00.16.1
ses npmFrom 0.16.00.16.1
ses npmFrom 0.17.00.17.1
ses npmFrom 0.17.00.17.1
ses npmFrom 0.18.00.18.7
ses npmFrom 0.18.00.18.7

Products include Agoric Ses.

How do I fix CVE-2023-39532?

Upgrade ses to a fixed version for your release line: 0.13.5, 0.14.5, 0.15.24 or 0.16.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-39532 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39532 exists.

Sources

Also known as GHSA-9c4h-3f7h-322r.

Is CVE-2023-39532 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free