{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow-providers-apache-drill and apache-airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-39553 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-drill to 2.4.3 or later.","what":"CVE-2023-39553 is a high-severity path traversal vulnerability in Apache Airflow Drill Provider, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-39553 and fix it if it is affected.\n\nWhat it is: CVE-2023-39553 is a high-severity path traversal vulnerability in Apache Airflow Drill Provider, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-39553 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-drill (PyPI): affected all versions; fixed in 2.4.3\n- apache-airflow-providers-apache-drill (PyPI): affected all versions; fixed in 2.4.3\n- apache-airflow-providers-apache-drill (PyPI): affected all versions; fixed in 2.4.3\n- apache-airflow (PyPI): affected all versions; fixed in 2.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39553/ (Markdown: https://insights.sbomify.com/CVE-2023-39553/index.md)","id":"CVE-2023-39553","markdown":"https://insights.sbomify.com/CVE-2023-39553/index.md","name":"CVE-2023-39553","record":{"aliases":["GHSA-mq4v-6vg4-796c","PYSEC-2023-136","PYSEC-2026-1137"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow Drill Provider","requires_auth":"none","summary":"An attacker can read arbitrary files on the Airflow server by passing malicious parameters to the DrillHook connection.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-apache-drill","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider.\n\nApache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server.\nThis issue affects Apache Airflow Drill Provider: before 2.4.3.\nIt is recommended to upgrade to a version that is not affected.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Drill Provider Arbitrary File Read Vulnerability","id":"CVE-2023-39553","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-39558"},"packages":[{"ecosystem":"PyPI","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2023-136"},{"ecosystem":"PyPI","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-drill","purl":null,"source":"GHSA-mq4v-6vg4-796c"},{"ecosystem":"PyPI","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-drill","purl":"pkg:pypi/apache-airflow-providers-apache-drill","source":"GHSA-mq4v-6vg4-796c"},{"ecosystem":"PyPI","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-drill","purl":"pkg:pypi/apache-airflow-providers-apache-drill","source":"PYSEC-2026-1137"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2023-39551"},"products":["Apache Airflow Drill Provider"],"published":"2023-08-11","related":[{"cvss_score":7.5,"headline":"Airflow Apache Drill Provider Arbitrary File Read Vulnerability","id":"CVE-2023-28707","kev_date_added":null,"published":"2023-04-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"An attacker can read arbitrary files on the Airflow server by passing malicious parameters to the DrillHook connection.","url":"https://insights.sbomify.com/CVE-2023-39553/"}