# CVE-2023-39553: Apache Airflow Drill Provider Arbitrary File Read Vulnerability

> An attacker can read arbitrary files on the Airflow server by passing malicious parameters to the DrillHook connection.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-mq4v-6vg4-796c, PYSEC-2023-136, PYSEC-2026-1137

## What is CVE-2023-39553?

CVE-2023-39553 is a high-severity path traversal vulnerability in Apache Airflow Drill Provider, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider.

Apache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server.
This issue affects Apache Airflow Drill Provider: before 2.4.3.
It is recommended to upgrade to a version that is not affected.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-39553?

4 open source packages ship an affected version, including apache-airflow-providers-apache-drill and apache-airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-drill` | PyPI | All versions | 2.4.3 |
| `apache-airflow-providers-apache-drill` | PyPI | All versions | 2.4.3 |
| `apache-airflow-providers-apache-drill` | PyPI | All versions | 2.4.3 |
| `apache-airflow` | PyPI | All versions | 2.4.3 |

Products: Apache Apache-Airflow-Providers-Apache-Drill.

## How do I fix CVE-2023-39553?

Upgrade apache-airflow-providers-apache-drill to 2.4.3 or later.

## Is CVE-2023-39553 being exploited?

There is no known exploitation of CVE-2023-39553 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Drill Provider

- [CVE-2023-28707](https://insights.sbomify.com/CVE-2023-28707/): Airflow Apache Drill Provider Arbitrary File Read Vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39553 and fix it if it is affected.

What it is: CVE-2023-39553 is a high-severity path traversal vulnerability in Apache Airflow Drill Provider, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39553 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-drill (PyPI): affected all versions; fixed in 2.4.3
- apache-airflow-providers-apache-drill (PyPI): affected all versions; fixed in 2.4.3
- apache-airflow-providers-apache-drill (PyPI): affected all versions; fixed in 2.4.3
- apache-airflow (PyPI): affected all versions; fixed in 2.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39553/ (Markdown: https://insights.sbomify.com/CVE-2023-39553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39553
- OSV: https://osv.dev/vulnerability/CVE-2023-39553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39553/
Summaries are generated and may contain mistakes; the official description above is the record.
