CVE-2023-3958 WP Remote Users Sync <= 1.2.12 - Authenticated (Subscriber+) Server Side Request Forgery

High 8.5 Published Updated

Authenticated subscribers can exploit SSRF in WP Remote Users Sync to query and modify internal services via the notify_ping_remote function.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-3958?

CVE-2023-3958 is a high-severity server-side request forgery vulnerability in frogerme WP Remote Users Sync, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The WP Remote Users Sync plugin for WordPress is vulnerable to Server Side Request Forgery via the 'notify_ping_remote' AJAX function in versions up to, and including, 1.2.12. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This was partially patched in version 1.2.12 and fully patched in version 1.2.13.

Weakness: CWE-918

Which versions are affected by CVE-2023-3958?

It affects 1 product.

Products include Froger Wp Remote Users Sync.

How do I fix CVE-2023-3958?

No fix has been published for CVE-2023-3958 yet. Limit exposure of the affected software until one is available.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2023-3958 being exploited?

There is no known exploitation of CVE-2023-3958 in the wild and no public exploit code.

Sources

Also known as GHSA-jxpw-qh57-h233.

Is CVE-2023-3958 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free