{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-3958 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-3958 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-3958 is a high-severity server-side request forgery vulnerability in frogerme WP Remote Users Sync, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-3958 and fix it if it is affected.\n\nWhat it is: CVE-2023-3958 is a high-severity server-side request forgery vulnerability in frogerme WP Remote Users Sync, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-3958 in the wild and no public exploit code.\n\nAffected product: frogerme WP Remote Users Sync. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3958/ (Markdown: https://insights.sbomify.com/CVE-2023-3958/index.md)","id":"CVE-2023-3958","markdown":"https://insights.sbomify.com/CVE-2023-3958/index.md","name":"CVE-2023-3958","record":{"aliases":["GHSA-jxpw-qh57-h233"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can exploit SSRF in WP Remote Users Sync to query and modify internal services via the notify_ping_remote function.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wp_remote_users_sync","vendor":"froger"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The WP Remote Users Sync plugin for WordPress is vulnerable to Server Side Request Forgery via the 'notify_ping_remote' AJAX function in versions up to, and including, 1.2.12. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This was partially patched in version 1.2.12 and fully patched in version 1.2.13.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WP Remote Users Sync \u003c= 1.2.12 - Authenticated (Subscriber+) Server Side Request Forgery","id":"CVE-2023-3958","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":0,"n_references":4,"next":{"headline":"Zavio IP Camera Stack-Based Buffer Overflow","id":"CVE-2023-3959"},"packages":[],"prev":{"headline":"ACF Photo Gallery Field \u003c= 1.9 - Authenticated (Subscriber+) Arbitrary Usermeta Update","id":"CVE-2023-3957"},"products":["WP Remote Users Sync"],"published":"2023-08-16","related":[{"cvss_score":4.3,"headline":"WP Remote Users Sync \u003c= 1.2.11 - Missing Authorization to Authenticated (Subscriber+) Log View","id":"CVE-2023-4374","kev_date_added":null,"published":"2023-08-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["frogerme"]},"summary":"Authenticated subscribers can exploit SSRF in WP Remote Users Sync to query and modify internal services via the notify_ping_remote function.","url":"https://insights.sbomify.com/CVE-2023-3958/"}