# CVE-2023-3958: WP Remote Users Sync <= 1.2.12 - Authenticated (Subscriber+) Server Side Request Forgery

> Authenticated subscribers can exploit SSRF in WP Remote Users Sync to query and modify internal services via the notify_ping_remote function.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2023
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-jxpw-qh57-h233

## What is CVE-2023-3958?

CVE-2023-3958 is a high-severity server-side request forgery vulnerability in frogerme WP Remote Users Sync, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The WP Remote Users Sync plugin for WordPress is vulnerable to Server Side Request Forgery via the 'notify_ping_remote' AJAX function in versions up to, and including, 1.2.12. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This was partially patched in version 1.2.12 and fully patched in version 1.2.13.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-3958?

It affects 1 product.


Products: Froger Wp Remote Users Sync.

## How do I fix CVE-2023-3958?

No fix has been published for CVE-2023-3958 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-3958 being exploited?

There is no known exploitation of CVE-2023-3958 in the wild and no public exploit code.

## Other vulnerabilities in frogerme WP Remote Users Sync

- [CVE-2023-4374](https://insights.sbomify.com/CVE-2023-4374/): WP Remote Users Sync <= 1.2.11 - Missing Authorization to Authenticated (Subscriber+) Log View (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3958 and fix it if it is affected.

What it is: CVE-2023-3958 is a high-severity server-side request forgery vulnerability in frogerme WP Remote Users Sync, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-3958 in the wild and no public exploit code.

Affected product: frogerme WP Remote Users Sync. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3958/ (Markdown: https://insights.sbomify.com/CVE-2023-3958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3958
- OSV: https://osv.dev/vulnerability/CVE-2023-3958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3958/
Summaries are generated and may contain mistakes; the official description above is the record.
