CVE-2023-3964 Incorrect Authorization in GitLab

Medium 4.3 Published Updated

Attackers can access composer packages in public projects even when the package registry is disabled, exposing unintended data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3964?

CVE-2023-3964 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 13.2 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for users to access composer packages on public projects that have package registry disabled in the project settings.

Weakness: CWE-863

Which versions are affected by CVE-2023-3964?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.2.016.4.3, 16.5.3, 16.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3964?

Upgrade gitlab to a fixed version for your release line: 16.4.3, 16.5.3 or 16.6.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-3964 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3964 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3964, GHSA-7m6x-h8vx-f72m.

Is CVE-2023-3964 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free