{"answers":{"affected":"3 open source packages ship an affected version, including pandasai. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39660 exists.","fix":"Upgrade pandasai to 0.8.1 or later.","what":"CVE-2023-39660 is a critical code injection vulnerability in n/a, published on 21 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-39660 and fix it if it is affected.\n\nWhat it is: CVE-2023-39660 is a critical code injection vulnerability in n/a, published on 21 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39660 exists.\n\nAffected packages and fixed versions:\n- pandasai (PyPI): affected all versions; fixed in 0.8.1\n- pandasai (PyPI): affected all versions; fixed in 0.8.1\n- pandasai (PyPI): affected all versions; fixed in 0.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39660/ (Markdown: https://insights.sbomify.com/CVE-2023-39660/index.md)","id":"CVE-2023-39660","markdown":"https://insights.sbomify.com/CVE-2023-39660/index.md","name":"CVE-2023-39660","record":{"aliases":["GHSA-w832-v3c6-m6rg","PYSEC-2026-1757"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python data science library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via crafted requests to the prompt function in the pandasai library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pandasai","vendor":"gabrieleventuri"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pandasai vulnerable to prompt injection","id":"CVE-2023-39660","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"PandasAI vulnerable to arbitrary code execution","id":"CVE-2023-39661"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"pandasai","purl":null,"source":"GHSA-w832-v3c6-m6rg"},{"ecosystem":"PyPI","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"pandasai","purl":"pkg:pypi/pandasai","source":"GHSA-w832-v3c6-m6rg"},{"ecosystem":"PyPI","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"pandasai","purl":"pkg:pypi/pandasai","source":"PYSEC-2026-1757"}],"prev":{"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659"},"products":["n/a"],"published":"2023-08-21","related":[{"cvss_score":9.8,"headline":"Code execution in pandasai","id":"CVE-2024-23752","kev_date_added":null,"published":"2024-01-22"},{"cvss_score":9.8,"headline":"PandasAI vulnerable to arbitrary code execution","id":"CVE-2023-39661","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":7.3,"headline":"SQL injection in n/a","id":"CVE-2026-30273","kev_date_added":null,"published":"2026-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via crafted requests to the prompt function in the pandasai library.","url":"https://insights.sbomify.com/CVE-2023-39660/"}