# CVE-2023-39660: pandasai vulnerable to prompt injection

> Remote attackers can execute arbitrary code via crafted requests to the prompt function in the pandasai library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2023
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-w832-v3c6-m6rg, PYSEC-2026-1757

## What is CVE-2023-39660?

CVE-2023-39660 is a critical code injection vulnerability in n/a, published on 21 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-39660?

3 open source packages ship an affected version, including pandasai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pandasai` | PyPI | All versions | 0.8.1 |
| `pandasai` | PyPI | All versions | 0.8.1 |
| `pandasai` | PyPI | All versions | 0.8.1 |

Products: Gabrieleventuri Pandasai.

## How do I fix CVE-2023-39660?

Upgrade pandasai to 0.8.1 or later.

## Is CVE-2023-39660 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39660 exists.

## Other vulnerabilities in n/a

- [CVE-2024-23752](https://insights.sbomify.com/CVE-2024-23752/): Code execution in pandasai (critical 9.8)
- [CVE-2023-39661](https://insights.sbomify.com/CVE-2023-39661/): PandasAI vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2026-30273](https://insights.sbomify.com/CVE-2026-30273/): SQL injection in n/a (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39660 and fix it if it is affected.

What it is: CVE-2023-39660 is a critical code injection vulnerability in n/a, published on 21 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39660 exists.

Affected packages and fixed versions:
- pandasai (PyPI): affected all versions; fixed in 0.8.1
- pandasai (PyPI): affected all versions; fixed in 0.8.1
- pandasai (PyPI): affected all versions; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39660/ (Markdown: https://insights.sbomify.com/CVE-2023-39660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39660
- OSV: https://osv.dev/vulnerability/CVE-2023-39660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39660/
Summaries are generated and may contain mistakes; the official description above is the record.
