CVE-2023-3979 Incorrect Authorization in GitLab

Low 3.1 Published Updated

Upstream collaborators can improperly write to merge request source branches, allowing unauthorized code modification in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3979?

CVE-2023-3979 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 29 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 10.6 before 16.2.8, all versions starting from 16.3 before 16.3.5, all versions starting from 16.4 before 16.4.1. It was possible that upstream members to collaborate with you on your branch get permission to write to the merge request’s source branch.

Weakness: CWE-863

Which versions are affected by CVE-2023-3979?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.6.016.2.8, 16.3.5, 16.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3979?

Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-3979 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3979 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3979, GHSA-ppjq-2qhc-pjp7, UBUNTU-CVE-2023-3979.

Is CVE-2023-3979 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free