{"answers":{"affected":"3 open source packages ship an affected version, including bcder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-39914 in the wild and no public exploit code.","fix":"Upgrade bcder to 0.7.3 or later.","what":"CVE-2023-39914 is a high-severity denial of service vulnerability in NLnet Labs bcder, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-39914 and fix it if it is affected.\n\nWhat it is: CVE-2023-39914 is a high-severity denial of service vulnerability in NLnet Labs bcder, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-39914 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bcder (crates.io): affected all versions; fixed in 0.7.3\n- bcder (crates.io): affected all versions; fixed in 0.7.3\n- bcder (crates.io): affected from 0.0.0-0; fixed in 0.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39914/ (Markdown: https://insights.sbomify.com/CVE-2023-39914/index.md)","id":"CVE-2023-39914","markdown":"https://insights.sbomify.com/CVE-2023-39914/index.md","name":"CVE-2023-39914","record":{"aliases":["DEBIAN-CVE-2023-39914","GHSA-6jmw-6mxw-w4jc","RUSTSEC-2023-0062"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust BER decoder library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing invalid input to the bcder library, triggering a panic during decoding.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"NLnet Labs","cpe":[{"product":"bcder","vendor":"nlnetlabs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-240","name":"Improper Handling of Inconsistent Structural Elements"},{"id":"CWE-232","name":"Improper Handling of Undefined Values"}],"description":"NLnet Labs' bcder library up to and including version 0.7.2 panics while decoding certain invalid input data rather than rejecting the data with an error. This can affect both the actual decoding stage as well as accessing content of types that utilized delayed decoding.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"BER/CER/DER decoder panics on invalid input","id":"CVE-2023-39914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"Crashes on parsing certain invalid RPKI objects","id":"CVE-2023-39915"},"packages":[{"ecosystem":"crates.io","fixed":["0.7.3"],"introduced":["0"],"last_affected":[],"package":"bcder","purl":null,"source":"GHSA-6jmw-6mxw-w4jc"},{"ecosystem":"crates.io","fixed":["0.7.3"],"introduced":["0"],"last_affected":[],"package":"bcder","purl":"pkg:cargo/bcder","source":"GHSA-6jmw-6mxw-w4jc"},{"ecosystem":"crates.io","fixed":["0.7.3"],"introduced":["0.0.0-0"],"last_affected":[],"package":"bcder","purl":"pkg:cargo/bcder","source":"RUSTSEC-2023-0062"}],"prev":{"headline":"Apache UIMA Java SDK Deserialization of Untrusted Data, Improper Input Validation vulnerability","id":"CVE-2023-39913"},"products":["bcder"],"published":"2023-09-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-12","vendors":["NLnet Labs"]},"summary":"An attacker can cause a denial of service by providing invalid input to the bcder library, triggering a panic during decoding.","url":"https://insights.sbomify.com/CVE-2023-39914/"}