# CVE-2023-39914: BER/CER/DER decoder panics on invalid input

> An attacker can cause a denial of service by providing invalid input to the bcder library, triggering a panic during decoding.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2023
- **Updated:** 12 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-39914, GHSA-6jmw-6mxw-w4jc, RUSTSEC-2023-0062

## What is CVE-2023-39914?

CVE-2023-39914 is a high-severity denial of service vulnerability in NLnet Labs bcder, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLnet Labs' bcder library up to and including version 0.7.2 panics while decoding certain invalid input data rather than rejecting the data with an error. This can affect both the actual decoding stage as well as accessing content of types that utilized delayed decoding.

Weakness: CWE-240 (Improper Handling of Inconsistent Structural Elements), CWE-232 (Improper Handling of Undefined Values)

## Which versions are affected by CVE-2023-39914?

3 open source packages ship an affected version, including bcder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bcder` | crates.io | All versions | 0.7.3 |
| `bcder` | crates.io | All versions | 0.7.3 |
| `bcder` | crates.io | From 0.0.0-0 | 0.7.3 |

Products: Nlnetlabs Bcder.

## How do I fix CVE-2023-39914?

Upgrade bcder to 0.7.3 or later.

## Is CVE-2023-39914 being exploited?

There is no known exploitation of CVE-2023-39914 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39914 and fix it if it is affected.

What it is: CVE-2023-39914 is a high-severity denial of service vulnerability in NLnet Labs bcder, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39914 in the wild and no public exploit code.

Affected packages and fixed versions:
- bcder (crates.io): affected all versions; fixed in 0.7.3
- bcder (crates.io): affected all versions; fixed in 0.7.3
- bcder (crates.io): affected from 0.0.0-0; fixed in 0.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39914/ (Markdown: https://insights.sbomify.com/CVE-2023-39914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39914
- OSV: https://osv.dev/vulnerability/CVE-2023-39914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39914/
Summaries are generated and may contain mistakes; the official description above is the record.
