CVE-2023-3994 Inefficient Regular Expression Complexity in GitLab

High 7.5 Published Updated

Attackers can cause denial of service in GitLab by sending crafted payloads to the preview_markdown endpoint, exploiting inefficient regular expressions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3994?

CVE-2023-3994 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 2 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 9.3 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. A Regular Expression Denial of Service was possible via sending crafted payloads which use ProjectReferenceFilter to the preview_markdown endpoint.

Weakness: CWE-1333

Which versions are affected by CVE-2023-3994?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.3.016.0.8, 16.1.3, 16.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-3994?

Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-3994 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3994 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3994, GHSA-5jfm-fvc2-73xf, UBUNTU-CVE-2023-3994.

Is CVE-2023-3994 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free