# CVE-2023-39956: Electron: Out-of-package code execution when launched with arbitrary cwd

> Attackers can execute arbitrary code by launching Electron apps with a controlled working directory, bypassing ASAR integrity protections.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-7x97-j373-85x5

## What is CVE-2023-39956?

CVE-2023-39956 is a medium-severity code injection vulnerability in Electronjs Electron, published on 6 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS. Electron apps that are launched as command line executables are impacted.   Specifically this issue can only be exploited if the following conditions are met: 1. The app is launched with an attacker-controlled working directory and 2. The attacker has the ability to write files to that working directory. This makes the risk quite low, in fact normally issues of this kind are considered outside of our threat model as similar to Chromium we exclude Physically Local Attacks but given the ability for this issue to bypass certain protections like ASAR Integrity it is being treated with higher importance.  This issue has been fixed in versions:`26.0.0-beta.13`, `25.4.1`, `24.7.1`, `23.3.13`, and `22.3.19`. There are no app side workarounds, users must update to a patched version of Electron.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-39956?

10 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 22.3.19 |
| `electron` | npm | All versions | 22.3.19 |
| `electron` | npm | From 23.0.0-alpha.1 | 23.3.13 |
| `electron` | npm | From 23.0.0-alpha.1 | 23.3.13 |
| `electron` | npm | From 24.0.0-alpha.1 | 24.7.1 |
| `electron` | npm | From 24.0.0-alpha.1 | 24.7.1 |
| `electron` | npm | From 25.0.0-alpha.1 | 25.5.0 |
| `electron` | npm | From 25.0.0-alpha.1 | 25.5.0 |
| `electron` | npm | From 26.0.0-alpha.1 | 26.0.0-beta.13 |
| `electron` | npm | From 26.0.0-alpha.1 | 26.0.0-beta.13 |

Products: Electronjs Electron.

## How do I fix CVE-2023-39956?

Upgrade electron to a fixed version for your release line: 22.3.19, 23.3.13, 24.7.1 or 25.5.0.

## Is CVE-2023-39956 being exploited?

There is no known exploitation of CVE-2023-39956 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39956 and fix it if it is affected.

What it is: CVE-2023-39956 is a medium-severity code injection vulnerability in Electronjs Electron, published on 6 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-39956 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 22.3.19
- electron (npm): affected all versions; fixed in 22.3.19
- electron (npm): affected from 23.0.0-alpha.1; fixed in 23.3.13
- electron (npm): affected from 23.0.0-alpha.1; fixed in 23.3.13
- electron (npm): affected from 24.0.0-alpha.1; fixed in 24.7.1
- electron (npm): affected from 24.0.0-alpha.1; fixed in 24.7.1
- electron (npm): affected from 25.0.0-alpha.1; fixed in 25.5.0
- electron (npm): affected from 25.0.0-alpha.1; fixed in 25.5.0
- electron (npm): affected from 26.0.0-alpha.1; fixed in 26.0.0-beta.13
- electron (npm): affected from 26.0.0-alpha.1; fixed in 26.0.0-beta.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39956/ (Markdown: https://insights.sbomify.com/CVE-2023-39956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39956
- OSV: https://osv.dev/vulnerability/CVE-2023-39956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39956/
Summaries are generated and may contain mistakes; the official description above is the record.
