# CVE-2023-39964: 1Panel O&M management panel has a background arbitrary file reading vulnerability

> An attacker can read arbitrary configuration files on the server due to unfiltered path parameters in the file loading function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2023
- **Updated:** 4 Oct 2024
- **Also known as:** GHSA-pv7q-v9mv-9mh5, GO-2023-2004

## What is CVE-2023-39964?

CVE-2023-39964 is a high-severity path traversal vulnerability in 1Panel-dev 1Panel, published on 10 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

1Panel is an open source Linux server operation and maintenance management panel. In version 1.4.3, arbitrary file reads allow an attacker to read arbitrary important configuration files on the server. In the `api/v1/file.go` file, there is a function called `LoadFromFile`, which directly reads the file by obtaining the requested path `parameter[path]`. The request parameters are not filtered, resulting in a background arbitrary file reading vulnerability. Version 1.5.0 has a patch for this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-39964?

3 open source packages ship an affected version, including github.com/1Panel-dev/1Panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel` | Go | From 1.4.3 | 1.5.0 |
| `github.com/1Panel-dev/1Panel` | Go | From 1.4.3 | 1.5.0 |
| `github.com/1Panel-dev/1Panel` | Go | From 1.4.3 | 1.5.0 |

Products: Fit2cloud 1panel.

## How do I fix CVE-2023-39964?

Upgrade github.com/1Panel-dev/1Panel to 1.5.0 or later.

## Is CVE-2023-39964 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39964 exists.

## Other vulnerabilities in 1Panel-dev 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-54424](https://insights.sbomify.com/CVE-2025-54424/): 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution (high 8.1)
- [CVE-2025-66507](https://insights.sbomify.com/CVE-2025-66507/): 1Panel – CAPTCHA Bypass via Client-Controlled Flag (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39964 and fix it if it is affected.

What it is: CVE-2023-39964 is a high-severity path traversal vulnerability in 1Panel-dev 1Panel, published on 10 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39964 exists.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel (Go): affected from 1.4.3; fixed in 1.5.0
- github.com/1Panel-dev/1Panel (Go): affected from 1.4.3; fixed in 1.5.0
- github.com/1Panel-dev/1Panel (Go): affected from 1.4.3; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39964/ (Markdown: https://insights.sbomify.com/CVE-2023-39964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39964
- OSV: https://osv.dev/vulnerability/CVE-2023-39964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39964/
Summaries are generated and may contain mistakes; the official description above is the record.
