# CVE-2023-39965: 1Panel Unauthorized access in Backend

> Attackers can download arbitrary files from the target system via an unauthorized API interface, leading to significant information leakage.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Aug 2023
- **Updated:** 4 Oct 2024
- **Also known as:** GHSA-85cf-gj29-f555, GO-2023-2005

## What is CVE-2023-39965?

CVE-2023-39965 is a medium-severity missing authorization vulnerability in 1Panel-dev 1Panel, published on 10 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

1Panel is an open source Linux server operation and maintenance management panel. In version 1.4.3, authenticated attackers can download arbitrary files through the API interface. This code has unauthorized access. Attackers can freely download the file content on the target system. This may cause a large amount of information leakage. Version 1.5.0 has a patch for this issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-39965?

3 open source packages ship an affected version, including github.com/1Panel-dev/1Panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel` | Go | From 1.4.3 | 1.5.0 |
| `github.com/1Panel-dev/1Panel` | Go | From 1.4.3 | 1.5.0 |
| `github.com/1Panel-dev/1Panel` | Go | From 1.4.3 | 1.5.0 |

Products: Fit2cloud 1panel.

## How do I fix CVE-2023-39965?

Upgrade github.com/1Panel-dev/1Panel to 1.5.0 or later.

## Is CVE-2023-39965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39965 exists.

## Other vulnerabilities in 1Panel-dev 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-54424](https://insights.sbomify.com/CVE-2025-54424/): 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution (high 8.1)
- [CVE-2025-66507](https://insights.sbomify.com/CVE-2025-66507/): 1Panel – CAPTCHA Bypass via Client-Controlled Flag (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39965 and fix it if it is affected.

What it is: CVE-2023-39965 is a medium-severity missing authorization vulnerability in 1Panel-dev 1Panel, published on 10 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39965 exists.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel (Go): affected from 1.4.3; fixed in 1.5.0
- github.com/1Panel-dev/1Panel (Go): affected from 1.4.3; fixed in 1.5.0
- github.com/1Panel-dev/1Panel (Go): affected from 1.4.3; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39965/ (Markdown: https://insights.sbomify.com/CVE-2023-39965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39965
- OSV: https://osv.dev/vulnerability/CVE-2023-39965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39965/
Summaries are generated and may contain mistakes; the official description above is the record.
