# CVE-2023-40015: Vyper: reversed order of side effects for some operations

> Vyper compiler evaluates certain operations right-to-left, causing logic errors when arguments have side effects, impacting smart contract security.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2023
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-g2xh-c426-v8mf, PYSEC-2023-167

## What is CVE-2023-40015?

CVE-2023-40015 is a low-severity vulnerability in vyperlang vyper, published on 4 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a Pythonic Smart Contract Language. For the following (probably non-exhaustive) list of expressions, the compiler evaluates the arguments from right to left instead of left to right. `unsafe_add, unsafe_sub, unsafe_mul, unsafe_div, pow_mod256, |, &, ^ (bitwise operators), bitwise_or (deprecated), bitwise_and (deprecated), bitwise_xor (deprecated), raw_call, <, >, <=, >=, ==, !=, in, not in (when lhs and rhs are enums)`. This behaviour becomes a problem when the evaluation of one of the arguments produces side effects that other arguments depend on. The following expressions can produce side-effect: state modifying external call , state modifying internal call, `raw_call`, `pop()` when used on a Dynamic Array stored in the storage, `create_minimal_proxy_to`, `create_copy_of`, `create_from_blueprint`. This issue has not yet been patched. Users are advised to make sure that the arguments of the expression do not produce side effects or, if one does, that no other argument is dependent on those side effects.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2023-40015?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions to 0.4.2 | None |
| `vyper` | PyPI | All versions to 0.4.2 | None |
| `vyper` | PyPI | All versions | 0.3.10rc1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2023-40015?

Upgrade vyper to 0.3.10rc1 or later.

## Is CVE-2023-40015 being exploited?

There is no known exploitation of CVE-2023-40015 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40015 and fix it if it is affected.

What it is: CVE-2023-40015 is a low-severity vulnerability in vyperlang vyper, published on 4 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40015 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions up to 0.4.2; no fix listed
- vyper (PyPI): affected all versions up to 0.4.2; no fix listed
- vyper (PyPI): affected all versions; fixed in 0.3.10rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40015/ (Markdown: https://insights.sbomify.com/CVE-2023-40015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40015
- OSV: https://osv.dev/vulnerability/CVE-2023-40015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40015/
Summaries are generated and may contain mistakes; the official description above is the record.
