# CVE-2023-40017: Geonode Server Side Request Forgery vulnerability

> An attacker can exploit a proxy endpoint to port scan internal hosts and access internal network resources in GeoNode.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-rmxg-6qqf-x8mr, PYSEC-2023-269

## What is CVE-2023-40017?

CVE-2023-40017 is a high-severity server-side request forgery vulnerability in geonode, published on 24 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GeoNode is an open source platform that facilitates the creation, sharing, and collaborative use of geospatial data. In versions 3.2.0 through 4.1.2, the endpoint `/proxy/?url=` does not properly protect against server-side request forgery. This allows an attacker to port scan internal hosts and request information from internal hosts. A patch is available at commit a9eebae80cb362009660a1fd49e105e7cdb499b9.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-40017?

3 open source packages ship an affected version, including geonode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `geonode` | PyPI | From 3.2.0 | 4.1.3 |
| `geonode` | PyPI | From 3.2.0 | 4.2.0 |
| `geonode` | PyPI | From 3.2.0 | 4.2.0 |

Products: Geosolutionsgroup Geonode.

## How do I fix CVE-2023-40017?

Upgrade geonode to a fixed version for your release line: 4.1.3 or 4.2.0.

## Is CVE-2023-40017 being exploited?

There is no known exploitation of CVE-2023-40017 in the wild and no public exploit code.

## Other vulnerabilities in geonode

- [CVE-2023-42439](https://insights.sbomify.com/CVE-2023-42439/): GeoNode SSRF Bypass to return internal host data (high 7.5)
- [CVE-2023-28442](https://insights.sbomify.com/CVE-2023-28442/): Geoserver for GeoNode sensitive information leak (high 7.5)
- [CVE-2023-26043](https://insights.sbomify.com/CVE-2023-26043/): XML External Entity (XXE) injection in GeoServer style upload functionality (medium 6.5)
- [CVE-2024-27091](https://insights.sbomify.com/CVE-2024-27091/): GeoNode stored XSS to full account takeover (medium 6.1)
- [CVE-2026-39921](https://insights.sbomify.com/CVE-2026-39921/): GeoNode < 4.4.5, 5.0.2 SSRF via Document Upload (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40017 and fix it if it is affected.

What it is: CVE-2023-40017 is a high-severity server-side request forgery vulnerability in geonode, published on 24 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40017 in the wild and no public exploit code.

Affected packages and fixed versions:
- geonode (PyPI): affected from 3.2.0; fixed in 4.1.3
- geonode (PyPI): affected from 3.2.0; fixed in 4.2.0
- geonode (PyPI): affected from 3.2.0; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40017/ (Markdown: https://insights.sbomify.com/CVE-2023-40017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40017
- OSV: https://osv.dev/vulnerability/CVE-2023-40017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40017/
Summaries are generated and may contain mistakes; the official description above is the record.
