CVE-2023-4002 Insertion of Sensitive Information Into Sent Data in GitLab
GitLab EE users can link security policy projects by ID, potentially revealing configured security policies to unauthorized users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-4002?
CVE-2023-4002 is a medium-severity vulnerability in Gitlab Gitlab, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 14.1 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible for EE-licensed users to link any security policy project by its ID to projects or groups the user has access to, potentially revealing the security projects's configured security policies.
Weakness: CWE-201
Which versions are affected by CVE-2023-4002?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.1.0 | 16.0.8, 16.1.3, 16.2.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-4002?
Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.
Is CVE-2023-4002 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4002 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-4002, GHSA-fh9c-h28h-pf65.