{"answers":{"affected":"1 open source package ship an affected version, including gitlab. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4002 exists.","fix":"Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.","what":"CVE-2023-4002 is a medium-severity vulnerability in Gitlab Gitlab, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-4002 and fix it if it is affected.\n\nWhat it is: CVE-2023-4002 is a medium-severity vulnerability in Gitlab Gitlab, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4002 exists.\n\nAffected packages and fixed versions:\n- gitlab (Bitnami): affected from 14.1.0; fixed in 16.0.8, 16.1.3, 16.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-4002/ (Markdown: https://insights.sbomify.com/CVE-2023-4002/index.md)","id":"CVE-2023-4002","markdown":"https://insights.sbomify.com/CVE-2023-4002/index.md","name":"CVE-2023-4002","record":{"aliases":["BIT-gitlab-2023-4002","GHSA-fh9c-h28h-pf65"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GitLab Enterprise Edition","requires_auth":"low_privilege","summary":"GitLab EE users can link security policy projects by ID, potentially revealing configured security policies to unauthorized users.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitLab","cpe":[{"product":"gitlab","vendor":"gitlab"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-201","name":"Insertion of Sensitive Information Into Sent Data"}],"description":"An issue has been discovered in GitLab EE affecting all versions starting from 14.1 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible for EE-licensed users to link any security policy project by its ID to projects or groups the user has access to, potentially revealing the security projects's configured security policies.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Insertion of Sensitive Information Into Sent Data in GitLab","id":"CVE-2023-4002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"gitlab:gitlab","products":["gitlab:gitlab"],"type":"information_disclosure","year":"2023"},"n_packages":1,"n_references":1,"next":{"headline":"One Identity Password Manager version 5.9.7.1 - Unauthenticated physical access privilege escalation","id":"CVE-2023-4003"},"packages":[{"ecosystem":"Bitnami","fixed":["16.0.8","16.1.3","16.2.2"],"introduced":["14.1.0","16.1.0","16.2.0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2023-4002"}],"prev":{"headline":"Grub2: bypass the grub password protection feature","id":"CVE-2023-4001"},"products":["GitLab"],"published":"2023-08-04","related":[{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound","id":"CVE-2026-97229","kev_date_added":"2026-10-29","published":"2026-10-13"},{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Path Traversal","id":"CVE-2026-85706","kev_date_added":"2026-09-11","published":"2026-09-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Improper Access Control","id":"CVE-2023-7028","kev_date_added":"2024-05-01","published":"2024-01-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Remote Code Execution","id":"CVE-2021-22205","kev_date_added":"2021-11-03","published":"2021-04-23"},{"cvss_score":6.8,"headline":"GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)","id":"CVE-2021-39935","kev_date_added":"2026-02-03","published":"2021-12-13"},{"cvss_score":6.8,"headline":"GitLab Server-Side Request Forgery (SSRF)","id":"CVE-2021-22175","kev_date_added":"2026-02-18","published":"2021-06-11"},{"cvss_score":10,"headline":"Integer Overflow or Wraparound in GitLab","id":"CVE-2026-110264","kev_date_added":null,"published":"2026-10-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-02","vendors":["GitLab"]},"summary":"GitLab EE users can link security policy projects by ID, potentially revealing configured security policies to unauthorized users.","url":"https://insights.sbomify.com/CVE-2023-4002/"}