{"answers":{"affected":"3 open source packages ship an affected version, including github.com/yaklang/yaklang. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-40023 in the wild and no public exploit code.","fix":"Upgrade github.com/yaklang/yaklang to 1.2.4-sp2 or later.","what":"CVE-2023-40023 is a medium-severity path traversal vulnerability in yaklang, published on 14 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-40023 and fix it if it is affected.\n\nWhat it is: CVE-2023-40023 is a medium-severity path traversal vulnerability in yaklang, published on 14 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-40023 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/yaklang/yaklang (Go): affected all versions; fixed in 1.2.4-sp2\n- github.com/yaklang/yaklang (Go): affected all versions; fixed in 1.2.4-sp2\n- github.com/yaklang/yaklang (Go): affected all versions; fixed in 1.2.4-sp2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-40023/ (Markdown: https://insights.sbomify.com/CVE-2023-40023/index.md)","id":"CVE-2023-40023","markdown":"https://insights.sbomify.com/CVE-2023-40023/index.md","name":"CVE-2023-40023","record":{"aliases":["GHSA-xvhg-w6qc-m3qq","GO-2023-2011"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Yaklang security tool","requires_auth":"none","summary":"Attackers can read local files and potentially execute code via a local file inclusion vulnerability in the Yaklang Fuzztag component.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yaklang","vendor":"yaklang"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"yaklang is a programming language designed for cybersecurity. The Yak Engine has been found to contain a local file inclusion (LFI) vulnerability. This vulnerability allows attackers to include files from the server's local file system through the web application. When exploited, this can lead to the unintended exposure of sensitive data, potential remote code execution, or other security breaches. Users utilizing versions of the Yak Engine prior to 1.2.4-sp1 are impacted. This vulnerability has been patched in version 1.2.4-sp1. Users are advised to upgrade. users unable to upgrade may avoid exposing vulnerable versions to untrusted input and to closely monitor any unexpected server behavior until they can upgrade.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yaklang Plugin's Fuzztag Component Allows Unauthorized Local File Reading","id":"CVE-2023-40023","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Reflected Cross-Site Scripting (XSS) in scancode.io license endpoint","id":"CVE-2023-40024"},"packages":[{"ecosystem":"Go","fixed":["1.2.4-sp2"],"introduced":["0"],"last_affected":[],"package":"github.com/yaklang/yaklang","purl":null,"source":"GHSA-xvhg-w6qc-m3qq"},{"ecosystem":"Go","fixed":["1.2.4-sp2"],"introduced":["0"],"last_affected":[],"package":"github.com/yaklang/yaklang","purl":"pkg:golang/github.com/yaklang/yaklang","source":"GHSA-xvhg-w6qc-m3qq"},{"ecosystem":"Go","fixed":["1.2.4-sp2"],"introduced":["0"],"last_affected":[],"package":"github.com/yaklang/yaklang","purl":"pkg:golang/github.com/yaklang/yaklang","source":"GO-2023-2011"}],"prev":{"headline":"Rizin vulnerable to Integer Overflow in C++ demangler logic","id":"CVE-2023-40022"},"products":["yaklang"],"published":"2023-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-01","vendors":["yaklang"]},"summary":"Attackers can read local files and potentially execute code via a local file inclusion vulnerability in the Yaklang Fuzztag component.","url":"https://insights.sbomify.com/CVE-2023-40023/"}