# CVE-2023-40023: Yaklang Plugin's Fuzztag Component Allows Unauthorized Local File Reading

> Attackers can read local files and potentially execute code via a local file inclusion vulnerability in the Yaklang Fuzztag component.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2023
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-xvhg-w6qc-m3qq, GO-2023-2011

## What is CVE-2023-40023?

CVE-2023-40023 is a medium-severity path traversal vulnerability in yaklang, published on 14 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yaklang is a programming language designed for cybersecurity. The Yak Engine has been found to contain a local file inclusion (LFI) vulnerability. This vulnerability allows attackers to include files from the server's local file system through the web application. When exploited, this can lead to the unintended exposure of sensitive data, potential remote code execution, or other security breaches. Users utilizing versions of the Yak Engine prior to 1.2.4-sp1 are impacted. This vulnerability has been patched in version 1.2.4-sp1. Users are advised to upgrade. users unable to upgrade may avoid exposing vulnerable versions to untrusted input and to closely monitor any unexpected server behavior until they can upgrade.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-40023?

3 open source packages ship an affected version, including github.com/yaklang/yaklang. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/yaklang/yaklang` | Go | All versions | 1.2.4-sp2 |
| `github.com/yaklang/yaklang` | Go | All versions | 1.2.4-sp2 |
| `github.com/yaklang/yaklang` | Go | All versions | 1.2.4-sp2 |

Products: Yaklang Yaklang.

## How do I fix CVE-2023-40023?

Upgrade github.com/yaklang/yaklang to 1.2.4-sp2 or later.

## Is CVE-2023-40023 being exploited?

There is no known exploitation of CVE-2023-40023 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40023 and fix it if it is affected.

What it is: CVE-2023-40023 is a medium-severity path traversal vulnerability in yaklang, published on 14 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-40023 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/yaklang/yaklang (Go): affected all versions; fixed in 1.2.4-sp2
- github.com/yaklang/yaklang (Go): affected all versions; fixed in 1.2.4-sp2
- github.com/yaklang/yaklang (Go): affected all versions; fixed in 1.2.4-sp2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40023/ (Markdown: https://insights.sbomify.com/CVE-2023-40023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40023
- OSV: https://osv.dev/vulnerability/CVE-2023-40023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40023/
Summaries are generated and may contain mistakes; the official description above is the record.
