# CVE-2023-40027: Conditionally missing authorization in @keystone-6/core

> Attackers can access admin metadata without authentication if ui.isAccessAllowed is undefined, exposing sensitive configuration data.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-9cvc-v7wm-992c

## What is CVE-2023-40027?

CVE-2023-40027 is a low-severity missing authorization vulnerability in keystonejs keystone, published on 15 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Keystone is an open source headless CMS for Node.js — built with GraphQL and React. When `ui.isAccessAllowed` is set as `undefined`, the `adminMeta` GraphQL query is publicly accessible (no session required). This is different to the behaviour of the default AdminUI middleware, which by default will only be publicly accessible (no session required) if a `session` strategy is not defined. This vulnerability does not affect developers using the `@keystone-6/auth` package, or any users that have written their own `ui.isAccessAllowed` (that is to say, `isAccessAllowed` is not `undefined`). This vulnerability does affect users who believed that their `session` strategy will, by default, enforce that `adminMeta` is inaccessible by the public in accordance with that strategy; akin to the behaviour of the AdminUI middleware. This vulnerability has been patched in `@keystone-6/core` version `5.5.1`. Users are advised to upgrade. Users unable to upgrade may opt to write their own `isAccessAllowed` functionality to work-around this vulnerability.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-40027?

2 open source packages ship an affected version, including @keystone-6/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@keystone-6/core` | npm | All versions | 5.5.1 |
| `@keystone-6/core` | npm | All versions | 5.5.1 |

Products: Keystonejs Keystone.

## How do I fix CVE-2023-40027?

Upgrade @keystone-6/core to 5.5.1 or later.

## Is CVE-2023-40027 being exploited?

There is no known exploitation of CVE-2023-40027 in the wild and no public exploit code.

## Other vulnerabilities in keystonejs keystone

- [CVE-2022-39382](https://insights.sbomify.com/CVE-2022-39382/): NODE_ENV in Keystone defaults to development with esbuild (critical 9.8)
- [CVE-2022-29354](https://insights.sbomify.com/CVE-2022-29354/): File upload in n/a (critical 9.8)
- [CVE-2022-39322](https://insights.sbomify.com/CVE-2022-39322/): @keystone-6/core vulnerable to field-level access-control bypass for multiselect field (critical 9.1)
- [CVE-2017-16570](https://insights.sbomify.com/CVE-2017-16570/): Cross-Site Request Forgery (CSRF) in keystone (high 8.8)
- [CVE-2017-15879](https://insights.sbomify.com/CVE-2017-15879/): Keystone is vulnerable to CSV injection (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40027 and fix it if it is affected.

What it is: CVE-2023-40027 is a low-severity missing authorization vulnerability in keystonejs keystone, published on 15 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40027 in the wild and no public exploit code.

Affected packages and fixed versions:
- @keystone-6/core (npm): affected all versions; fixed in 5.5.1
- @keystone-6/core (npm): affected all versions; fixed in 5.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40027/ (Markdown: https://insights.sbomify.com/CVE-2023-40027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40027
- OSV: https://osv.dev/vulnerability/CVE-2023-40027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40027/
Summaries are generated and may contain mistakes; the official description above is the record.
