# CVE-2023-40028: Arbitrary file read via symlinks in Ghost

> Authenticated users can upload symlinks to read arbitrary files on the host system in Ghost CMS.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** BIT-ghost-2023-40028, GHSA-9c9v-w225-v5rg

## What is CVE-2023-40028?

CVE-2023-40028 is a medium-severity path traversal vulnerability in TryGhost Ghost, published on 15 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ghost is an open source content management system. Versions prior to 5.59.1 are subject to a vulnerability which allows authenticated users to upload files that are symlinks. This can be exploited to perform an arbitrary file read of any file on the host operating system. Site administrators can check for exploitation of this issue by looking for unknown symlinks within Ghost's `content/` folder. Version 5.59.1 contains a fix for this issue. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-40028?

3 open source packages ship an affected version, including ghost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | All versions | 5.59.1 |
| `ghost` | npm | All versions | 5.59.1 |
| `ghost` | npm | All versions | 5.59.1 |

Products: Ghost Ghost.

## How do I fix CVE-2023-40028?

Upgrade ghost to 5.59.1 or later.

## Is CVE-2023-40028 being exploited?

There is no known exploitation of CVE-2023-40028 in the wild and no public exploit code.

Public exploit code:

- https://github.com/0xyassine/CVE-2023-40028 (github_poc): https://github.com/0xyassine/CVE-2023-40028
- CVE-2023-40028 affects Ghost, an open source content management system, where versions prior to 5.59.1 allow authenticated users to upload files that are symlinks. This can be exploited to perform an arbitrary file read of any file on the host operating system. (github_poc): https://github.com/0xDTC/Ghost-5.58-Arbitrary-File-Read-CVE-2023-40028
- Arbitrary file read in Ghost-CMS allows an attacker to upload a malicious ZIP file with a symlink. (github_poc): https://github.com/monke443/CVE-2023-40028
- CVE-2023-40028 PoC Exploit (github_poc): https://github.com/rvzsec/CVE-2023-40028
- Proof of concept for CVE-2023-40028: Ghost arbitrary file read (github_poc): https://github.com/godylockz/CVE-2023-40028
- Exploit for CVE-2023-40028 (for educational purposes) (github_poc): https://github.com/Stp1t/CVE-2023-40028

## Other vulnerabilities in TryGhost Ghost

- [CVE-2022-27139](https://insights.sbomify.com/CVE-2022-27139/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-28397](https://insights.sbomify.com/CVE-2022-28397/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-41654](https://insights.sbomify.com/CVE-2022-41654/): ghost vulnerable to unauthorized newsletter modification via improper access controls (critical 9.6)
- [CVE-2026-26980](https://insights.sbomify.com/CVE-2026-26980/): Ghost has a SQL Injection in its Content API (critical 9.4)
- [CVE-2024-34451](https://insights.sbomify.com/CVE-2024-34451/): Security feature bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40028 and fix it if it is affected.

What it is: CVE-2023-40028 is a medium-severity path traversal vulnerability in TryGhost Ghost, published on 15 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40028 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected all versions; fixed in 5.59.1
- ghost (npm): affected all versions; fixed in 5.59.1
- ghost (npm): affected all versions; fixed in 5.59.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40028/ (Markdown: https://insights.sbomify.com/CVE-2023-40028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40028
- OSV: https://osv.dev/vulnerability/CVE-2023-40028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40028/
Summaries are generated and may contain mistakes; the official description above is the record.
