{"answers":{"affected":"4 open source packages ship an affected version, including flarum/framework and flarum/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-40033 in the wild and no public exploit code.","fix":"Upgrade flarum/framework to 1.8.0 or later.","what":"CVE-2023-40033 is a high-severity server-side request forgery vulnerability in flarum framework, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-40033 and fix it if it is affected.\n\nWhat it is: CVE-2023-40033 is a high-severity server-side request forgery vulnerability in flarum framework, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-40033 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flarum/framework (Packagist): affected all versions; fixed in 1.8.0\n- flarum/framework (Packagist): affected all versions; fixed in 1.8.0\n- flarum/core (Packagist): affected all versions; fixed in 1.8.0\n- flarum/core (Packagist): affected all versions; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-40033/ (Markdown: https://insights.sbomify.com/CVE-2023-40033/index.md)","id":"CVE-2023-40033","markdown":"https://insights.sbomify.com/CVE-2023-40033/index.md","name":"CVE-2023-40033","record":{"aliases":["GHSA-67c6-q4j4-hccg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum forum software","requires_auth":"low_privilege","summary":"Attackers can perform SSRF or disclose local files by uploading crafted avatars, impacting confidentiality and server security.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flarum","vendor":"flarum"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack. This has been patched in Flarum version 1.8.0. Users are advised to upgrade. Users unable to upgrade may disable PHP's `allow_url_fopen` which will prevent the fetching of external files via URLs as a temporary workaround for the SSRF aspect of the vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery via Avatar upload in flarum","id":"CVE-2023-40033","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"Repositoty takeover in woodpecker-ci","id":"CVE-2023-40034"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-67c6-q4j4-hccg"},{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-67c6-q4j4-hccg"},{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"flarum/framework","purl":null,"source":"GHSA-67c6-q4j4-hccg"},{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"flarum/framework","purl":"pkg:composer/flarum/framework","source":"GHSA-67c6-q4j4-hccg"}],"prev":{"headline":"Potential segfault due to NULL pointer dereference in libvips","id":"CVE-2023-40032"},"products":["framework"],"published":"2023-08-16","related":[{"cvss_score":10,"headline":"XSS vulnerability with translator","id":"CVE-2021-32671","kev_date_added":null,"published":"2021-06-07"},{"cvss_score":9,"headline":"Cross site scripting vulnerability with discussion titles in flarum","id":"CVE-2022-41938","kev_date_added":null,"published":"2022-11-19"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13183","kev_date_added":null,"published":"2019-07-07"},{"cvss_score":7.7,"headline":"Post mentions can be used to read any post on the forum without access control","id":"CVE-2023-22487","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":7.5,"headline":"Flarum mishandles invalidation of user email tokens","id":"CVE-2019-11514","kev_date_added":null,"published":"2019-04-25"},{"cvss_score":6.8,"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794","kev_date_added":null,"published":"2025-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["flarum"]},"summary":"Attackers can perform SSRF or disclose local files by uploading crafted avatars, impacting confidentiality and server security.","url":"https://insights.sbomify.com/CVE-2023-40033/"}