# CVE-2023-40033: Server-Side Request Forgery via Avatar upload in flarum

> Attackers can perform SSRF or disclose local files by uploading crafted avatars, impacting confidentiality and server security.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-67c6-q4j4-hccg

## What is CVE-2023-40033?

CVE-2023-40033 is a high-severity server-side request forgery vulnerability in flarum framework, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack. This has been patched in Flarum version 1.8.0. Users are advised to upgrade. Users unable to upgrade may disable PHP's `allow_url_fopen` which will prevent the fetching of external files via URLs as a temporary workaround for the SSRF aspect of the vulnerability.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-40033?

4 open source packages ship an affected version, including flarum/framework and flarum/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flarum/framework` | Packagist | All versions | 1.8.0 |
| `flarum/framework` | Packagist | All versions | 1.8.0 |
| `flarum/core` | Packagist | All versions | 1.8.0 |
| `flarum/core` | Packagist | All versions | 1.8.0 |

Products: Flarum Flarum.

## How do I fix CVE-2023-40033?

Upgrade flarum/framework to 1.8.0 or later.

## Is CVE-2023-40033 being exploited?

There is no known exploitation of CVE-2023-40033 in the wild and no public exploit code.

## Other vulnerabilities in flarum framework

- [CVE-2021-32671](https://insights.sbomify.com/CVE-2021-32671/): XSS vulnerability with translator (critical 10.0)
- [CVE-2022-41938](https://insights.sbomify.com/CVE-2022-41938/): Cross site scripting vulnerability with discussion titles in flarum (critical 9.0)
- [CVE-2019-13183](https://insights.sbomify.com/CVE-2019-13183/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2023-22487](https://insights.sbomify.com/CVE-2023-22487/): Post mentions can be used to read any post on the forum without access control (high 7.7)
- [CVE-2019-11514](https://insights.sbomify.com/CVE-2019-11514/): Flarum mishandles invalidation of user email tokens (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40033 and fix it if it is affected.

What it is: CVE-2023-40033 is a high-severity server-side request forgery vulnerability in flarum framework, published on 16 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40033 in the wild and no public exploit code.

Affected packages and fixed versions:
- flarum/framework (Packagist): affected all versions; fixed in 1.8.0
- flarum/framework (Packagist): affected all versions; fixed in 1.8.0
- flarum/core (Packagist): affected all versions; fixed in 1.8.0
- flarum/core (Packagist): affected all versions; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40033/ (Markdown: https://insights.sbomify.com/CVE-2023-40033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40033
- OSV: https://osv.dev/vulnerability/CVE-2023-40033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40033/
Summaries are generated and may contain mistakes; the official description above is the record.
