# CVE-2023-40034: Repositoty takeover in woodpecker-ci

> Attackers can take over repositories by sending malformed webhook data if the CI system is publicly accessible.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-4gcf-5m39-98mc, GO-2023-2014

## What is CVE-2023-40034?

CVE-2023-40034 is a high-severity vulnerability in woodpecker-ci woodpecker, published on 16 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Woodpecker is a community fork of the Drone CI system. In affected versions an attacker can post malformed webhook data witch lead to an update of the repository data that can e.g. allow the takeover of an repo. This is only critical if the CI is configured for public usage and connected to a forge witch is also in public usage. This issue has been addressed in version 1.0.2. Users are advised to upgrade. Users unable to upgrade should secure the CI system by making it inaccessible to untrusted entities, for example, by placing it behind a firewall.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-40034?

3 open source packages ship an affected version, including github.com/woodpecker-ci/woodpecker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/woodpecker-ci/woodpecker` | Go | From 1.0.0 | 1.0.2 |
| `github.com/woodpecker-ci/woodpecker` | Go | From 1.0.0 | 1.0.2 |
| `github.com/woodpecker-ci/woodpecker` | Go | From 1.0.0 | 1.0.2 |

Products: Woodpecker-Ci Woodpecker.

## How do I fix CVE-2023-40034?

Upgrade github.com/woodpecker-ci/woodpecker to 1.0.2 or later.

## Is CVE-2023-40034 being exploited?

There is no known exploitation of CVE-2023-40034 in the wild and no public exploit code.

## Other vulnerabilities in woodpecker-ci woodpecker

- [CVE-2024-41121](https://insights.sbomify.com/CVE-2024-41121/): Custom workspace allow to overwrite plugin entrypoint executable in Woodpecker (high 8.8)
- [CVE-2024-41122](https://insights.sbomify.com/CVE-2024-41122/): Custom environment variables allow to alter execution flow of plugins in Woodpecker (high 7.5)
- [CVE-2022-29947](https://insights.sbomify.com/CVE-2022-29947/): Woodpecker allows cross-site scripting (XSS) via build logs (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40034 and fix it if it is affected.

What it is: CVE-2023-40034 is a high-severity vulnerability in woodpecker-ci woodpecker, published on 16 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40034 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/woodpecker-ci/woodpecker (Go): affected from 1.0.0; fixed in 1.0.2
- github.com/woodpecker-ci/woodpecker (Go): affected from 1.0.0; fixed in 1.0.2
- github.com/woodpecker-ci/woodpecker (Go): affected from 1.0.0; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40034/ (Markdown: https://insights.sbomify.com/CVE-2023-40034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40034
- OSV: https://osv.dev/vulnerability/CVE-2023-40034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40034/
Summaries are generated and may contain mistakes; the official description above is the record.
