# CVE-2023-40037: Apache NiFi: Incomplete Validation of JDBC and JNDI Connection URLs

> Authenticated users can bypass JDBC and JNDI connection URL validation in Apache NiFi using crafted inputs, potentially enabling unauthorized access or injection.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-nifi-2023-40037, GHSA-23qf-3jf9-h3q9

## What is CVE-2023-40037?

CVE-2023-40037 is a medium-severity vulnerability in Apache Nifi, published on 18 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache NiFi 1.21.0 through 1.23.0 support JDBC and JNDI JMS access in several Processors and Controller Services with connection URL validation that does not provide sufficient protection against crafted inputs. An authenticated and authorized user can bypass connection URL validation using custom input formatting. The resolution enhances connection URL validation and introduces validation for additional related properties. Upgrading to Apache NiFi 1.23.1 is the recommended mitigation.

Weakness: CWE-697 (Incorrect Comparison), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2023-40037?

9 open source packages ship an affected version, including org.apache.nifi:nifi-dbcp-base, nifi and org.apache.nifi:nifi-dbcp-service-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-dbcp-base` | Maven | From 1.21.0 | 1.23.1 |
| `org.apache.nifi:nifi-dbcp-base` | Maven | From 1.21.0 | 1.23.1 |
| `nifi` | Bitnami | From 1.21.0 | 1.23.1 |
| `org.apache.nifi:nifi-dbcp-service-api` | Maven | From 1.21.0 | 1.23.1 |
| `org.apache.nifi:nifi-dbcp-service-api` | Maven | From 1.21.0 | 1.23.1 |
| `org.apache.nifi:nifi-dbcp-service-bundle` | Maven | From 1.21.0 | 1.23.1 |
| `org.apache.nifi:nifi-dbcp-service-bundle` | Maven | From 1.21.0 | 1.23.1 |
| `org.apache.nifi:nifi-jms-processors` | Maven | From 1.21.0 | 1.23.1 |
| `org.apache.nifi:nifi-jms-processors` | Maven | From 1.21.0 | 1.23.1 |

Products: Apache Nifi.

## How do I fix CVE-2023-40037?

Upgrade org.apache.nifi:nifi-dbcp-base to 1.23.1 or later.

## Is CVE-2023-40037 being exploited?

There is no known exploitation of CVE-2023-40037 in the wild and no public exploit code.

Public exploit code:

- CVE-2023-40037: Incomplete Validation of JDBC and JNDI Connection URLs in Apache NiFi (github_poc): https://github.com/mbadanoiu/CVE-2023-40037

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40037 and fix it if it is affected.

What it is: CVE-2023-40037 is a medium-severity vulnerability in Apache Nifi, published on 18 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40037 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-dbcp-base (Maven): affected from 1.21.0; fixed in 1.23.1
- org.apache.nifi:nifi-dbcp-base (Maven): affected from 1.21.0; fixed in 1.23.1
- nifi (Bitnami): affected from 1.21.0; fixed in 1.23.1
- org.apache.nifi:nifi-dbcp-service-api (Maven): affected from 1.21.0; fixed in 1.23.1
- org.apache.nifi:nifi-dbcp-service-api (Maven): affected from 1.21.0; fixed in 1.23.1
- org.apache.nifi:nifi-dbcp-service-bundle (Maven): affected from 1.21.0; fixed in 1.23.1
- org.apache.nifi:nifi-dbcp-service-bundle (Maven): affected from 1.21.0; fixed in 1.23.1
- org.apache.nifi:nifi-jms-processors (Maven): affected from 1.21.0; fixed in 1.23.1
- org.apache.nifi:nifi-jms-processors (Maven): affected from 1.21.0; fixed in 1.23.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40037/ (Markdown: https://insights.sbomify.com/CVE-2023-40037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40037
- OSV: https://osv.dev/vulnerability/CVE-2023-40037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40037/
Summaries are generated and may contain mistakes; the official description above is the record.
