# CVE-2023-4006: Improper Neutralization of Formula Elements in a CSV File in thorsten/phpmyfaq

> An attacker can execute arbitrary code by injecting formula elements into CSV files exported from phpMyFAQ.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2023
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-2xvx-368h-qcmv

## What is CVE-2023-4006?

CVE-2023-4006 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 31 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Formula Elements in a CSV File in GitHub repository thorsten/phpmyfaq prior to 3.1.16.

Weakness: CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2023-4006?

2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 3.1.16 |
| `thorsten/phpmyfaq` | Packagist | All versions | 3.1.16 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2023-4006?

Upgrade thorsten/phpmyfaq to 3.1.16 or later.

## Is CVE-2023-4006 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4006 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4006 and fix it if it is affected.

What it is: CVE-2023-4006 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 31 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4006 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.16
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4006/ (Markdown: https://insights.sbomify.com/CVE-2023-4006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4006
- OSV: https://osv.dev/vulnerability/CVE-2023-4006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4006/
Summaries are generated and may contain mistakes; the official description above is the record.
