# CVE-2023-40167: Jetty accepts "+" prefixed value in Content-Length

> Jetty improperly accepts plus-prefixed Content-Length headers, potentially enabling request smuggling in specific proxy configurations.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLEANSTART-2025-JQ80087, CLEANSTART-2026-AW54675, CLEANSTART-2026-ID49738, DEBIAN-CVE-2023-40167, ECHO-996c-7d65-3491, GHSA-hmr7-m48g-48f6, MINI-26cw-mrv8-76xm, MINI-7xw9-968j-4566, MINI-rjxh-58fh-p47p, UBUNTU-CVE-2023-40167

## What is CVE-2023-40167?

CVE-2023-40167 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jetty is a Java based web server and servlet engine. Prior to versions 9.4.52, 10.0.16, 11.0.16, and 12.0.1, Jetty accepts the `+` character proceeding the content-length value in a HTTP/1 header field.  This is more permissive than allowed by the RFC and other servers routinely reject such requests with 400 responses.  There is no known exploit scenario, but it is conceivable that request smuggling could result if jetty is used in combination with a server that does not close the connection after sending such a 400 response. Versions 9.4.52, 10.0.16, 11.0.16, and 12.0.1 contain a patch for this issue. There is no workaround as there is no known exploit scenario.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2023-40167?

8 open source packages ship an affected version, including org.eclipse.jetty:jetty-http. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-http` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty:jetty-http` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty:jetty-http` | Maven | From 11.0.0 | 11.0.16 |
| `org.eclipse.jetty:jetty-http` | Maven | From 11.0.0 | 11.0.16 |
| `org.eclipse.jetty:jetty-http` | Maven | From 12.0.0 | 12.0.1 |
| `org.eclipse.jetty:jetty-http` | Maven | From 12.0.0 | 12.0.1 |
| `org.eclipse.jetty:jetty-http` | Maven | From 9.0.0 | 9.4.52 |
| `org.eclipse.jetty:jetty-http` | Maven | From 9.0.0 | 9.4.52 |

Products: Debian Debian Linux, Eclipse Jetty.

## How do I fix CVE-2023-40167?

Upgrade org.eclipse.jetty:jetty-http to a fixed version for your release line: 10.0.16, 11.0.16, 12.0.1 or 9.4.52.

## Is CVE-2023-40167 being exploited?

There is no known exploitation of CVE-2023-40167 in the wild and no public exploit code.

Public exploit code:

- https://github.com/uthrasri/Jetty-v9.4.31_CVE-2023-40167 (github_poc): https://github.com/uthrasri/Jetty-v9.4.31_CVE-2023-40167

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40167 and fix it if it is affected.

What it is: CVE-2023-40167 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40167 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-http (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty:jetty-http (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty:jetty-http (Maven): affected from 11.0.0; fixed in 11.0.16
- org.eclipse.jetty:jetty-http (Maven): affected from 11.0.0; fixed in 11.0.16
- org.eclipse.jetty:jetty-http (Maven): affected from 12.0.0; fixed in 12.0.1
- org.eclipse.jetty:jetty-http (Maven): affected from 12.0.0; fixed in 12.0.1
- org.eclipse.jetty:jetty-http (Maven): affected from 9.0.0; fixed in 9.4.52
- org.eclipse.jetty:jetty-http (Maven): affected from 9.0.0; fixed in 9.4.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40167/ (Markdown: https://insights.sbomify.com/CVE-2023-40167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40167
- OSV: https://osv.dev/vulnerability/CVE-2023-40167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40167/
Summaries are generated and may contain mistakes; the official description above is the record.
