{"answers":{"affected":"2 open source packages ship an affected version, including @node-saml/node-saml. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40178 exists.","fix":"Upgrade @node-saml/node-saml to 4.0.5 or later.","what":"CVE-2023-40178 is a medium-severity vulnerability in node-saml, published on 23 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-40178 and fix it if it is affected.\n\nWhat it is: CVE-2023-40178 is a medium-severity vulnerability in node-saml, published on 23 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40178 exists.\n\nAffected packages and fixed versions:\n- @node-saml/node-saml (npm): affected all versions; fixed in 4.0.5\n- @node-saml/node-saml (npm): affected all versions; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-40178/ (Markdown: https://insights.sbomify.com/CVE-2023-40178/index.md)","id":"CVE-2023-40178","markdown":"https://insights.sbomify.com/CVE-2023-40178/index.md","name":"CVE-2023-40178","record":{"aliases":["GHSA-vx8m-6fhw-pccw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js SAML library","requires_auth":"none","summary":"Attackers can reuse expired SAML LogoutRequests to forcibly log out users, bypassing timestamp validation checks in the node-saml library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"node_saml","vendor":"node_saml_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"},{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"Node-SAML is a SAML library not dependent on any frameworks that runs in Node. The lack of checking of current timestamp allows a LogoutRequest XML to be reused multiple times even when the current time is past the NotOnOrAfter. This could impact the user where they would be logged out from an expired LogoutRequest. In bigger contexts, if LogoutRequests are sent out in mass to different SPs, this could impact many users on a large scale. This issue was patched in version 4.0.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@node-saml/node-saml's validatePostRequestAsync does not include checkTimestampsValidityError","id":"CVE-2023-40178","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Silverware Games vulnerable to account enumeration via inconsistent responses","id":"CVE-2023-40179"},"packages":[{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["0"],"last_affected":[],"package":"@node-saml/node-saml","purl":null,"source":"GHSA-vx8m-6fhw-pccw"},{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["0"],"last_affected":[],"package":"@node-saml/node-saml","purl":"pkg:npm/%40node-saml/node-saml","source":"GHSA-vx8m-6fhw-pccw"}],"prev":{"headline":"XWiki Platform privilege escalation (PR) from account through AWM content fields","id":"CVE-2023-40177"},"products":["node-saml"],"published":"2023-08-23","related":[{"cvss_score":7.7,"headline":"Signature bypass via multiple root elements in node-SAML","id":"CVE-2022-39300","kev_date_added":null,"published":"2022-10-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["node-saml"]},"summary":"Attackers can reuse expired SAML LogoutRequests to forcibly log out users, bypassing timestamp validation checks in the node-saml library.","url":"https://insights.sbomify.com/CVE-2023-40178/"}