CVE-2023-4018 Direct Request ('Forced Browsing') in GitLab
Attackers can create model experiments in public GitLab projects due to improper permission validation, allowing unauthorized data modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-4018?
CVE-2023-4018 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. Due to improper permission validation it was possible to create model experiments in public projects.
Weakness: CWE-425
Which versions are affected by CVE-2023-4018?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.2.0 | 16.2.5, 16.3.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-4018?
Upgrade gitlab to a fixed version for your release line: 16.2.5 or 16.3.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-4018 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4018 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-4018, GHSA-h98w-jf8x-jw68, UBUNTU-CVE-2023-4018.