# CVE-2023-40184: Improper handling of session establishment errors in xrdp

> Attackers can bypass PAM session restrictions like concurrent session limits by exploiting improper error handling in xrdp session establishment.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2023
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2023-40184, GHSA-f489-557v-47jq, MGASA-2023-0276, SUSE-SU-2023:3735-1, SUSE-SU-2023:3830-1, UBUNTU-CVE-2023-40184

## What is CVE-2023-40184?

CVE-2023-40184 is a low-severity vulnerability in neutrinolabs xrdp, published on 30 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

xrdp is an open source remote desktop protocol (RDP) server. In versions prior to 0.9.23 improper handling of session establishment errors allows bypassing OS-level session restrictions. The `auth_start_session` function can return non-zero (1) value on, e.g., PAM error which may result in in session restrictions such as max concurrent sessions per user by PAM (ex ./etc/security/limits.conf) to be bypassed. Users (administrators) don't use restrictions by PAM are not affected. This issue has been addressed in release version 0.9.23. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2023-40184?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xrdp` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 0.9.13.1-150200.4.24.1 |
| `xrdp` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 0.9.13.1-150200.4.24.1 |
| `xrdp` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 0.9.10-3.11.1 |
| `xrdp` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 0.9.10-3.11.1 |
| `xrdp` | SUSE:Manager Proxy 4.2 | All versions | 0.9.13.1-150200.4.24.1 |
| `xrdp` | SUSE:Manager Server 4.2 | All versions | 0.9.13.1-150200.4.24.1 |
| `xrdp` | openSUSE:Leap 15.4 | All versions | 0.9.13.1-150200.4.24.1 |
| `xrdp` | openSUSE:Leap 15.5 | All versions | 0.9.13.1-150200.4.24.1 |

Products: Neutrinolabs Xrdp.

## How do I fix CVE-2023-40184?

Upgrade to a fixed version.

## Is CVE-2023-40184 being exploited?

There is no known exploitation of CVE-2023-40184 in the wild and no public exploit code.

## Other vulnerabilities in neutrinolabs xrdp

- [CVE-2026-41252](https://insights.sbomify.com/CVE-2026-41252/): xrdp: lib_palette_update Heap Buffer Overflow & RCE (critical 9.8)
- [CVE-2026-32105](https://insights.sbomify.com/CVE-2026-32105/): xrdp: RDP MAC signature (dataSignature) never verified on receive — integrity bypass in non-TLS mode (critical 9.3)
- [CVE-2026-44178](https://insights.sbomify.com/CVE-2026-44178/): xrdp: Channel Data Forwarding Fixed-Size Buffer Overflow (high 8.8)
- [CVE-2026-32107](https://insights.sbomify.com/CVE-2026-32107/): xrdp: Fail-open privilege drop in sesexec — child processes may execute as root if setuid fails (high 8.8)
- [CVE-2026-33689](https://insights.sbomify.com/CVE-2026-33689/): xrdp: Pre-authentication out-of-bounds reads in channel parsers (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40184 and fix it if it is affected.

What it is: CVE-2023-40184 is a low-severity vulnerability in neutrinolabs xrdp, published on 30 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-40184 in the wild and no public exploit code.

Affected product: neutrinolabs xrdp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40184/ (Markdown: https://insights.sbomify.com/CVE-2023-40184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40184
- OSV: https://osv.dev/vulnerability/CVE-2023-40184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40184/
Summaries are generated and may contain mistakes; the official description above is the record.
