CVE-2023-40225 Other in n/a

High 7.2 Published Updated

HAProxy forwards empty Content-Length headers, potentially allowing HTTP request smuggling against backend servers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-40225?

CVE-2023-40225 is a high-severity vulnerability in n/a, published on 10 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

HAProxy through 2.0.32, 2.1.x and 2.2.x through 2.2.30, 2.3.x and 2.4.x through 2.4.23, 2.5.x and 2.6.x before 2.6.15, 2.7.x before 2.7.10, and 2.8.x before 2.8.2 forwards empty Content-Length headers, violating RFC 9110 section 8.6. In uncommon cases, an HTTP/1 server behind HAProxy may interpret the payload as an extra request.

Weakness: CWE-444

Which versions are affected by CVE-2023-40225?

1 open source package ship an affected version, including haproxy. It affects 1 product.

PackageAffectedFixed in
haproxy BitnamiAll versions2.0.33, 2.2.31, 2.4.24, 2.6.15, 2.7.10, 2.8.2
Linux distribution packages (23)
haproxy Red Hat:openshift:4.11::el8All versions0:2.2.24-4.rhaos4.11.el8
haproxy-debugsource Red Hat:openshift:4.11::el8All versions0:2.2.24-4.rhaos4.11.el8
haproxy22 Red Hat:openshift:4.11::el8All versions0:2.2.24-4.rhaos4.11.el8
haproxy22-debuginfo Red Hat:openshift:4.11::el8All versions0:2.2.24-4.rhaos4.11.el8
haproxy Red Hat:openshift:4.12::el8All versions0:2.2.24-4.rhaos4.12.el8
haproxy-debugsource Red Hat:openshift:4.12::el8All versions0:2.2.24-4.rhaos4.12.el8
haproxy22 Red Hat:openshift:4.12::el8All versions0:2.2.24-4.rhaos4.12.el8
haproxy22-debuginfo Red Hat:openshift:4.12::el8All versions0:2.2.24-4.rhaos4.12.el8
haproxy Red Hat:openshift:4.13::el8All versions0:2.2.24-4.rhaos4.13.el8
haproxy-debugsource Red Hat:openshift:4.13::el8All versions0:2.2.24-4.rhaos4.13.el8
haproxy22 Red Hat:openshift:4.13::el8All versions0:2.2.24-4.rhaos4.13.el8
haproxy22-debuginfo Red Hat:openshift:4.13::el8All versions0:2.2.24-4.rhaos4.13.el8
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP2All versions2.0.31-150200.11.23.1
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP3All versions2.0.31-150200.11.23.1
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP4All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP5All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy SUSE:Linux Enterprise Micro 5.3All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy SUSE:Linux Enterprise Micro 5.4All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy openSUSE:Leap 15.4All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy openSUSE:Leap 15.5All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy openSUSE:Leap Micro 5.3All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy openSUSE:Leap Micro 5.4All versions2.4.22+git0.f8e3218e2-150400.3.16.1
haproxy openSUSE:TumbleweedAll versions2.8.2+git0.61a0f576a-2.1

Products include Haproxy Haproxy.

How do I fix CVE-2023-40225?

Upgrade haproxy to a fixed version for your release line: 2.0.33, 2.2.31, 2.4.24 or 2.6.15.

Is CVE-2023-40225 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40225 exists.

Sources

Also known as AZL-27912, BIT-haproxy-2023-40225, CLSA-2025-1736503350, DEBIAN-CVE-2023-40225, GHSA-xgq7-jp95-v2qv, MGASA-2023-0320 and 10 more.

Is CVE-2023-40225 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free