# CVE-2023-40225: Other in n/a

> HAProxy forwards empty Content-Length headers, potentially allowing HTTP request smuggling against backend servers.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2023
- **Updated:** 9 Oct 2024
- **Also known as:** AZL-27912, BIT-haproxy-2023-40225, CLSA-2025-1736503350, DEBIAN-CVE-2023-40225, GHSA-xgq7-jp95-v2qv, MGASA-2023-0320, OESA-2023-1541, RHSA-2023:7606, RHSA-2024:0200, RHSA-2024:0308, SUSE-SU-2023:3469-1, SUSE-SU-2023:3490-1, UBUNTU-CVE-2023-40225, USN-6294-1, USN-6294-2, openSUSE-SU-2024:13116-1

## What is CVE-2023-40225?

CVE-2023-40225 is a high-severity vulnerability in n/a, published on 10 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAProxy through 2.0.32, 2.1.x and 2.2.x through 2.2.30, 2.3.x and 2.4.x through 2.4.23, 2.5.x and 2.6.x before 2.6.15, 2.7.x before 2.7.10, and 2.8.x before 2.8.2 forwards empty Content-Length headers, violating RFC 9110 section 8.6. In uncommon cases, an HTTP/1 server behind HAProxy may interpret the payload as an extra request.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-40225?

1 open source package ship an affected version, including haproxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | All versions | 2.0.33, 2.2.31, 2.4.24, 2.6.15, 2.7.10, 2.8.2 |
| `haproxy` | Red Hat:openshift:4.11::el8 | All versions | 0:2.2.24-4.rhaos4.11.el8 |
| `haproxy-debugsource` | Red Hat:openshift:4.11::el8 | All versions | 0:2.2.24-4.rhaos4.11.el8 |
| `haproxy22` | Red Hat:openshift:4.11::el8 | All versions | 0:2.2.24-4.rhaos4.11.el8 |
| `haproxy22-debuginfo` | Red Hat:openshift:4.11::el8 | All versions | 0:2.2.24-4.rhaos4.11.el8 |
| `haproxy` | Red Hat:openshift:4.12::el8 | All versions | 0:2.2.24-4.rhaos4.12.el8 |
| `haproxy-debugsource` | Red Hat:openshift:4.12::el8 | All versions | 0:2.2.24-4.rhaos4.12.el8 |
| `haproxy22` | Red Hat:openshift:4.12::el8 | All versions | 0:2.2.24-4.rhaos4.12.el8 |
| `haproxy22-debuginfo` | Red Hat:openshift:4.12::el8 | All versions | 0:2.2.24-4.rhaos4.12.el8 |
| `haproxy` | Red Hat:openshift:4.13::el8 | All versions | 0:2.2.24-4.rhaos4.13.el8 |
| `haproxy-debugsource` | Red Hat:openshift:4.13::el8 | All versions | 0:2.2.24-4.rhaos4.13.el8 |
| `haproxy22` | Red Hat:openshift:4.13::el8 | All versions | 0:2.2.24-4.rhaos4.13.el8 |
| `haproxy22-debuginfo` | Red Hat:openshift:4.13::el8 | All versions | 0:2.2.24-4.rhaos4.13.el8 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 2.0.31-150200.11.23.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 2.0.31-150200.11.23.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP5 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | SUSE:Linux Enterprise Micro 5.3 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | SUSE:Linux Enterprise Micro 5.4 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | openSUSE:Leap 15.4 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | openSUSE:Leap 15.5 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | openSUSE:Leap Micro 5.3 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | openSUSE:Leap Micro 5.4 | All versions | 2.4.22+git0.f8e3218e2-150400.3.16.1 |
| `haproxy` | openSUSE:Tumbleweed | All versions | 2.8.2+git0.61a0f576a-2.1 |

Products: Haproxy Haproxy.

## How do I fix CVE-2023-40225?

Upgrade haproxy to a fixed version for your release line: 2.0.33, 2.2.31, 2.4.24 or 2.6.15.

## Is CVE-2023-40225 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40225 exists.

## Other vulnerabilities in n/a

- [CVE-2026-55203](https://insights.sbomify.com/CVE-2026-55203/): HAProxy - Integer Overflow in FCGI Demux Record Length Field (critical 9.0)
- [CVE-2026-55204](https://insights.sbomify.com/CVE-2026-55204/): HAProxy - NULL Pointer Dereference in hpack_dht_insert Function (high 8.7)
- [CVE-2023-45539](https://insights.sbomify.com/CVE-2023-45539/): Information disclosure in n/a (high 8.2)
- [CVE-2024-45506](https://insights.sbomify.com/CVE-2024-45506/): Denial of service in n/a (high 7.5)
- [CVE-2023-0836](https://insights.sbomify.com/CVE-2023-0836/): Information disclosure in HAProxy (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40225 and fix it if it is affected.

What it is: CVE-2023-40225 is a high-severity vulnerability in n/a, published on 10 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40225 exists.

Affected packages and fixed versions:
- haproxy (Bitnami): affected all versions; fixed in 2.0.33, 2.2.31, 2.4.24, 2.6.15, 2.7.10, 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40225/ (Markdown: https://insights.sbomify.com/CVE-2023-40225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40225
- OSV: https://osv.dev/vulnerability/CVE-2023-40225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40225/
Summaries are generated and may contain mistakes; the official description above is the record.
