# CVE-2023-40267: GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments

> GitPython fails to block insecure clone options, allowing attackers to execute arbitrary commands via malicious repositories.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2023-40267, GHSA-pr76-5cm5-w9cj, PYSEC-2023-137, RHSA-2023:4991, UBUNTU-CVE-2023-40267, USN-6326-1, openSUSE-SU-2024:13146-1

## What is CVE-2023-40267?

CVE-2023-40267 is a critical command injection vulnerability in n/a, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitPython before 3.1.32 does not block insecure non-multi options in clone and clone_from. NOTE: this issue exists because of an incomplete fix for CVE-2022-24439.

## Which versions are affected by CVE-2023-40267?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.32 |
| `gitpython` | PyPI | All versions | 3.1.32 |
| `GitPython` | PyPI | All versions | 3.1.32 |
| `automation-controller-venv-tower` | Red Hat:ansible_automation_platform:2.3::el8 | All versions | 0:4.3.13-1.el8ap |
| `automation-controller-venv-tower` | Red Hat:ansible_automation_platform:2.3::el9 | All versions | 0:4.3.13-1.el9ap |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2023-40267?

Upgrade gitpython to 3.1.32 or later.

## Is CVE-2023-40267 being exploited?

There is no known exploitation of CVE-2023-40267 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)
- [CVE-2026-87819](https://insights.sbomify.com/CVE-2026-87819/): GitPython before 3.1.60 Denial of Service via ReDoS (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40267 and fix it if it is affected.

What it is: CVE-2023-40267 is a critical command injection vulnerability in n/a, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40267 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.32
- gitpython (PyPI): affected all versions; fixed in 3.1.32
- GitPython (PyPI): affected all versions; fixed in 3.1.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40267/ (Markdown: https://insights.sbomify.com/CVE-2023-40267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40267
- OSV: https://osv.dev/vulnerability/CVE-2023-40267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40267/
Summaries are generated and may contain mistakes; the official description above is the record.
