CVE-2023-40273 Session fixation in Apache Airflow web interface

High 8.0 Published Updated

Authenticated users retain access after password reset due to session fixation, bypassing intended security controls in Apache Airflow.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-40273?

CVE-2023-40273 is a high-severity vulnerability in Apache Airflow, published on 23 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

The session fixation vulnerability allowed the authenticated user to continue accessing Airflow webserver even after the password of the user has been reset by the admin - up until the expiry of the session of the user. Other than manually cleaning the session database (for database session backend), or changing the secure_key and restarting the webserver, there were no mechanisms to force-logout the user (and all other users with that).

With this fix implemented, when using the database session backend, the existing sessions of the user are invalidated when the password of the user is reset. When using the securecookie session backend, the sessions are NOT invalidated and still require changing the secure key and restarting the webserver (and logging out all other users), but the user resetting the password is informed about it with a flash message warning displayed in the UI. Documentation is also updated explaining this behaviour.

Users of Apache Airflow are advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability.

Weakness: CWE-384

Which versions are affected by CVE-2023-40273?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions2.7.0rc2
apache-airflow PyPIAll versions2.7.0rc2
apache-airflow PyPIAll versions2.7.1rc1
airflow BitnamiAll versions2.7.1

Products include Apache Airflow.

How do I fix CVE-2023-40273?

Upgrade apache-airflow to a fixed version for your release line: 2.7.0rc2 or 2.7.1rc1.

Is CVE-2023-40273 being exploited?

There is no known exploitation of CVE-2023-40273 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2023-40273, GHSA-pm87-24wq-r8w9, PYSEC-2023-158.

Is CVE-2023-40273 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free