# CVE-2023-40273: Session fixation in Apache Airflow web interface

> Authenticated users retain access after password reset due to session fixation, bypassing intended security controls in Apache Airflow.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Aug 2023
- **Updated:** 27 Sep 2024
- **Also known as:** BIT-airflow-2023-40273, GHSA-pm87-24wq-r8w9, PYSEC-2023-158

## What is CVE-2023-40273?

CVE-2023-40273 is a high-severity vulnerability in Apache Airflow, published on 23 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The session fixation vulnerability allowed the authenticated user to continue accessing Airflow webserver even after the password of the user has been reset by the admin - up until the expiry of the session of the user. Other than manually cleaning the session database (for database session backend), or changing the secure_key and restarting the webserver, there were no mechanisms to force-logout the user (and all other users with that).

With this fix implemented, when using the database session backend, the existing sessions of the user are invalidated when the password of the user is reset. When using the securecookie session backend, the sessions are NOT invalidated and still require changing the secure key and restarting the webserver (and logging out all other users), but the user resetting the password is informed about it with a flash message warning displayed in the UI. Documentation is also updated explaining this behaviour.

Users of Apache Airflow are advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2023-40273?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.7.0rc2 |
| `apache-airflow` | PyPI | All versions | 2.7.0rc2 |
| `apache-airflow` | PyPI | All versions | 2.7.1rc1 |
| `airflow` | Bitnami | All versions | 2.7.1 |

Products: Apache Airflow.

## How do I fix CVE-2023-40273?

Upgrade apache-airflow to a fixed version for your release line: 2.7.0rc2 or 2.7.1rc1.

## Is CVE-2023-40273 being exploited?

There is no known exploitation of CVE-2023-40273 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40273 and fix it if it is affected.

What it is: CVE-2023-40273 is a high-severity vulnerability in Apache Airflow, published on 23 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-40273 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0rc2
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0rc2
- apache-airflow (PyPI): affected all versions; fixed in 2.7.1rc1
- airflow (Bitnami): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40273/ (Markdown: https://insights.sbomify.com/CVE-2023-40273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40273
- OSV: https://osv.dev/vulnerability/CVE-2023-40273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40273/
Summaries are generated and may contain mistakes; the official description above is the record.
