CVE-2023-40313 Disable BeanShell Interpreter Remote Server Mode
Remote attackers can execute arbitrary Java code via BeanShell interpreter in OpenNMS Horizon and Meridian if remote server mode is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-40313?
CVE-2023-40313 is a high-severity code injection vulnerability in The OpenNMS Group Horizon, published on 17 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Weakness: CWE-94
Which versions are affected by CVE-2023-40313?
2 open source packages ship an affected version, including org.opennms:opennms-base-assembly. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.opennms:opennms-base-assembly Maven | All versions | 32.0.2 |
org.opennms:opennms-base-assembly Maven | All versions | 32.0.2 |
Products include Opennms Horizon, Opennms Meridian.
How do I fix CVE-2023-40313?
Upgrade org.opennms:opennms-base-assembly to 32.0.2 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-40313 being exploited?
There is no known exploitation of CVE-2023-40313 in the wild and no public exploit code.
Other vulnerabilities in The OpenNMS Group Horizon
- CVE-2021-25931 Cross-Site Request Forgery in OpenNMS Horizon
- CVE-2021-3396 OpenNMS Horizon RCE via JEXL2 expression
- CVE-2023-0872 ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users
- CVE-2023-0870 Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)
- CVE-2020-11886 SQL injection in n/a
Sources
Also known as GHSA-5m5f-qg8r-p9qf.