{"answers":{"affected":"2 open source packages ship an affected version, including org.opennms:opennms-webapp. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-40314 in the wild and no public exploit code.","fix":"Upgrade org.opennms:opennms-webapp to 32.0.5 or later.","what":"CVE-2023-40314 is a medium-severity cross-site scripting vulnerability in Horizon, published on 16 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-40314 and fix it if it is affected.\n\nWhat it is: CVE-2023-40314 is a medium-severity cross-site scripting vulnerability in Horizon, published on 16 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-40314 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 32.0.5\n- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 32.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-40314/ (Markdown: https://insights.sbomify.com/CVE-2023-40314/index.md)","id":"CVE-2023-40314","markdown":"https://insights.sbomify.com/CVE-2023-40314/index.md","name":"CVE-2023-40314","record":{"aliases":["GHSA-c6xw-hg9q-3c9f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Network monitoring software","requires_auth":"low_privilege","summary":"Cross-site scripting in bootstrap.jsp allows attackers to steal confidential session information from OpenNMS Horizon and Meridian users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"OpenNMS","cpe":[{"product":"horizon","vendor":"opennms"},{"product":"meridian","vendor":"opennms"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer\n\nMeridian\nand Horizon installation instructions state that they are intended for\ninstallation within an organization's private networks and should not be\ndirectly accessible from the Internet. \n\nOpenNMS thanks \n\nMoshe Apelbaum\n\n for reporting this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in bootstrap.jsp","id":"CVE-2023-40314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"ROLE_FILESYSTEM_EDITOR Can Be Used To Escalate To ROLE_ADMIN","id":"CVE-2023-40315"},"packages":[{"ecosystem":"Maven","fixed":["32.0.5"],"introduced":["0"],"last_affected":[],"package":"org.opennms:opennms-webapp","purl":null,"source":"GHSA-c6xw-hg9q-3c9f"},{"ecosystem":"Maven","fixed":["32.0.5"],"introduced":["0"],"last_affected":[],"package":"org.opennms:opennms-webapp","purl":"pkg:maven/org.opennms/opennms-webapp","source":"GHSA-c6xw-hg9q-3c9f"}],"prev":{"headline":"Disable BeanShell Interpreter Remote Server Mode","id":"CVE-2023-40313"},"products":["Horizon","Meridian"],"published":"2023-11-16","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in OpenNMS Horizon","id":"CVE-2021-25931","kev_date_added":null,"published":"2021-05-20"},{"cvss_score":8.8,"headline":"OpenNMS Horizon RCE via JEXL2 expression","id":"CVE-2021-3396","kev_date_added":null,"published":"2021-02-17"},{"cvss_score":8.2,"headline":"ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users","id":"CVE-2023-0872","kev_date_added":null,"published":"2023-08-14"},{"cvss_score":8.1,"headline":"Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)","id":"CVE-2023-0870","kev_date_added":null,"published":"2023-03-22"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2020-11886","kev_date_added":null,"published":"2020-04-17"},{"cvss_score":7.1,"headline":"Disable BeanShell Interpreter Remote Server Mode","id":"CVE-2023-40313","kev_date_added":null,"published":"2023-08-17"},{"cvss_score":6.8,"headline":"Plaintext Password Present in the Web logs","id":"CVE-2023-0815","kev_date_added":null,"published":"2023-02-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-29","vendors":[" The OpenNMS Group","The OpenNMS Group "]},"summary":"Cross-site scripting in bootstrap.jsp allows attackers to steal confidential session information from OpenNMS Horizon and Meridian users.","url":"https://insights.sbomify.com/CVE-2023-40314/"}