# CVE-2023-40314: Cross-site scripting in bootstrap.jsp

> Cross-site scripting in bootstrap.jsp allows attackers to steal confidential session information from OpenNMS Horizon and Meridian users.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Nov 2023
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-c6xw-hg9q-3c9f

## What is CVE-2023-40314?

CVE-2023-40314 is a medium-severity cross-site scripting vulnerability in Horizon, published on 16 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer

Meridian
and Horizon installation instructions state that they are intended for
installation within an organization's private networks and should not be
directly accessible from the Internet. 

OpenNMS thanks 

Moshe Apelbaum

 for reporting this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-40314?

2 open source packages ship an affected version, including org.opennms:opennms-webapp. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opennms:opennms-webapp` | Maven | All versions | 32.0.5 |
| `org.opennms:opennms-webapp` | Maven | All versions | 32.0.5 |

Products: Opennms Horizon, Opennms Meridian.

## How do I fix CVE-2023-40314?

Upgrade org.opennms:opennms-webapp to 32.0.5 or later.

## Is CVE-2023-40314 being exploited?

There is no known exploitation of CVE-2023-40314 in the wild and no public exploit code.

## Other vulnerabilities in Horizon

- [CVE-2021-25931](https://insights.sbomify.com/CVE-2021-25931/): Cross-Site Request Forgery in OpenNMS Horizon (high 8.8)
- [CVE-2021-3396](https://insights.sbomify.com/CVE-2021-3396/): OpenNMS Horizon RCE via JEXL2 expression (high 8.8)
- [CVE-2023-0872](https://insights.sbomify.com/CVE-2023-0872/): ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users (high 8.2)
- [CVE-2023-0870](https://insights.sbomify.com/CVE-2023-0870/): Form Can Be Manipulated with Cross-Site Request Forgery (CSRF) (high 8.1)
- [CVE-2020-11886](https://insights.sbomify.com/CVE-2020-11886/): SQL injection in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40314 and fix it if it is affected.

What it is: CVE-2023-40314 is a medium-severity cross-site scripting vulnerability in Horizon, published on 16 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-40314 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 32.0.5
- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 32.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40314/ (Markdown: https://insights.sbomify.com/CVE-2023-40314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40314
- OSV: https://osv.dev/vulnerability/CVE-2023-40314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40314/
Summaries are generated and may contain mistakes; the official description above is the record.
