CVE-2023-40315 ROLE_FILESYSTEM_EDITOR Can Be Used To Escalate To ROLE_ADMIN

Medium 5.3 Published Updated

Users with filesystem editor role can escalate to admin privileges in OpenNMS Horizon and Meridian, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2023-40315?

CVE-2023-40315 is a medium-severity vulnerability in The OpenNMS Group Horizon, published on 17 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

In OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 and related Meridian versions, any user that has the ROLE_FILESYSTEM_EDITOR can easily escalate their privileges to ROLE_ADMIN or any other role. The solution is to upgrade to Meridian 2023.1.5 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Weakness: CWE-863

Which versions are affected by CVE-2023-40315?

2 open source packages ship an affected version, including org.opennms:opennms-webapp-rest. It affects 2 products.

PackageAffectedFixed in
org.opennms:opennms-webapp-rest MavenFrom 31.0.832.0.2
org.opennms:opennms-webapp-rest MavenFrom 31.0.832.0.2

Products include Opennms Horizon, Opennms Meridian.

How do I fix CVE-2023-40315?

Upgrade org.opennms:opennms-webapp-rest to 32.0.2 or later.

Is CVE-2023-40315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40315 exists.

Public exploit code: 1 Metasploit module.

Sources

Also known as GHSA-hf5p-f83x-5q2g.

Is CVE-2023-40315 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free