{"answers":{"affected":"2 open source packages ship an affected version, including org.opennms:opennms-webapp-rest. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40315 exists.","fix":"Upgrade org.opennms:opennms-webapp-rest to 32.0.2 or later.","what":"CVE-2023-40315 is a medium-severity vulnerability in The OpenNMS Group Horizon, published on 17 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-40315 and fix it if it is affected.\n\nWhat it is: CVE-2023-40315 is a medium-severity vulnerability in The OpenNMS Group Horizon, published on 17 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40315 exists.\n\nAffected packages and fixed versions:\n- org.opennms:opennms-webapp-rest (Maven): affected from 31.0.8; fixed in 32.0.2\n- org.opennms:opennms-webapp-rest (Maven): affected from 31.0.8; fixed in 32.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-40315/ (Markdown: https://insights.sbomify.com/CVE-2023-40315/index.md)","id":"CVE-2023-40315","markdown":"https://insights.sbomify.com/CVE-2023-40315/index.md","name":"CVE-2023-40315","record":{"aliases":["GHSA-hf5p-f83x-5q2g"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenNMS Horizon","requires_auth":"high_privilege","summary":"Users with filesystem editor role can escalate to admin privileges in OpenNMS Horizon and Meridian, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"OpenNMS","cpe":[{"product":"horizon","vendor":"opennms"},{"product":"meridian","vendor":"opennms"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"In OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 and related Meridian versions, any user that has the ROLE_FILESYSTEM_EDITOR can easily escalate their privileges to ROLE_ADMIN or any other role. The solution is to upgrade to Meridian 2023.1.5 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2023-07-01","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2023-07-01","kind":"metasploit","ref":"exploit/linux/http/opennms_horizon_authenticated_rce","stars":null,"title":"OpenNMS Horizon Authenticated RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"ROLE_FILESYSTEM_EDITOR Can Be Used To Escalate To ROLE_ADMIN","id":"CVE-2023-40315","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"WordPress Putler Connector for WooCommerce plugin \u003c= 2.12.0 - Unauthenticated Broken Access Control vulnerability","id":"CVE-2023-40327"},"packages":[{"ecosystem":"Maven","fixed":["32.0.2"],"introduced":["31.0.8"],"last_affected":[],"package":"org.opennms:opennms-webapp-rest","purl":null,"source":"GHSA-hf5p-f83x-5q2g"},{"ecosystem":"Maven","fixed":["32.0.2"],"introduced":["31.0.8"],"last_affected":[],"package":"org.opennms:opennms-webapp-rest","purl":"pkg:maven/org.opennms/opennms-webapp-rest","source":"GHSA-hf5p-f83x-5q2g"}],"prev":{"headline":"Cross-site scripting in bootstrap.jsp","id":"CVE-2023-40314"},"products":["Horizon","Meridian"],"published":"2023-08-17","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in OpenNMS Horizon","id":"CVE-2021-25931","kev_date_added":null,"published":"2021-05-20"},{"cvss_score":8.8,"headline":"OpenNMS Horizon RCE via JEXL2 expression","id":"CVE-2021-3396","kev_date_added":null,"published":"2021-02-17"},{"cvss_score":8.2,"headline":"ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users","id":"CVE-2023-0872","kev_date_added":null,"published":"2023-08-14"},{"cvss_score":8.1,"headline":"Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)","id":"CVE-2023-0870","kev_date_added":null,"published":"2023-03-22"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2020-11886","kev_date_added":null,"published":"2020-04-17"},{"cvss_score":7.1,"headline":"Disable BeanShell Interpreter Remote Server Mode","id":"CVE-2023-40313","kev_date_added":null,"published":"2023-08-17"},{"cvss_score":6.8,"headline":"Plaintext Password Present in the Web logs","id":"CVE-2023-0815","kev_date_added":null,"published":"2023-02-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-28","vendors":["The OpenNMS Group"]},"summary":"Users with filesystem editor role can escalate to admin privileges in OpenNMS Horizon and Meridian, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-40315/"}