# CVE-2023-40346: Jenkins Shortcut Job Plugin stored cross-site scripting vulnerability

> Attackers with job configuration privileges can inject malicious scripts via shortcut URLs, leading to stored XSS and potential session hijacking.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Aug 2023
- **Updated:** 8 Oct 2024
- **Also known as:** GHSA-jg35-vf67-gg2j

## What is CVE-2023-40346?

CVE-2023-40346 is a medium-severity cross-site scripting vulnerability in Jenkins Shortcut Job Plugin, published on 16 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Shortcut Job Plugin 0.4 and earlier does not escape the shortcut redirection URL, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to configure shortcut jobs.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-40346?

2 open source packages ship an affected version, including io.jenkins.plugins:shortcut-job. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:shortcut-job` | Maven | All versions | 0.5 |
| `io.jenkins.plugins:shortcut-job` | Maven | All versions | 0.5 |

Products: Jenkins Shortcut Job.

## How do I fix CVE-2023-40346?

Upgrade io.jenkins.plugins:shortcut-job to 0.5 or later.

## Is CVE-2023-40346 being exploited?

There is no known exploitation of CVE-2023-40346 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40346 and fix it if it is affected.

What it is: CVE-2023-40346 is a medium-severity cross-site scripting vulnerability in Jenkins Shortcut Job Plugin, published on 16 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-40346 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:shortcut-job (Maven): affected all versions; fixed in 0.5
- io.jenkins.plugins:shortcut-job (Maven): affected all versions; fixed in 0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40346/ (Markdown: https://insights.sbomify.com/CVE-2023-40346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40346
- OSV: https://osv.dev/vulnerability/CVE-2023-40346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40346/
Summaries are generated and may contain mistakes; the official description above is the record.
