# CVE-2023-40354: Information disclosure in n/a

> An attacker with local access can read cleartext passwords stored in configuration files when using the maxctrl create service command.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Aug 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-vx3w-mr85-r8vr

## What is CVE-2023-40354?

CVE-2023-40354 is a medium-severity vulnerability in n/a, published on 14 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in MariaDB MaxScale before 23.02.3. A user enters an encrypted password on a "maxctrl create service" command line, but this password is then stored in cleartext in the resulting .cnf file under /var/lib/maxscale/maxscale.cnf.d. The fixed versions are 2.5.28, 6.4.9, 22.08.8, and 23.02.3.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2023-40354?

It affects 1 product.


Products: Mariadb Maxscale.

## How do I fix CVE-2023-40354?

No fix has been published for CVE-2023-40354 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-40354 being exploited?

There is no known exploitation of CVE-2023-40354 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40354 and fix it if it is affected.

What it is: CVE-2023-40354 is a medium-severity vulnerability in n/a, published on 14 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40354 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40354/ (Markdown: https://insights.sbomify.com/CVE-2023-40354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40354
- OSV: https://osv.dev/vulnerability/CVE-2023-40354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40354/
Summaries are generated and may contain mistakes; the official description above is the record.
