CVE-2023-40570 Datasette 1.0 alpha series leaks names of databases and tables to unauthenticated users

Medium 5.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2023-40570?

CVE-2023-40570 is a medium-severity vulnerability in simonw datasette, published on 25 Aug 2023.

Official description

Datasette is an open source multi-tool for exploring and publishing data. This bug affects Datasette instances running a Datasette 1.0 alpha - 1.0a0, 1.0a1, 1.0a2 or 1.0a3 - in an online accessible location but with authentication enabled using a plugin such as datasette-auth-passwords. The `/-/api` API explorer endpoint could reveal the names of both databases and tables - but not their contents - to an unauthenticated user. Datasette 1.0a4 has a fix for this issue. This will block access to the API explorer but will still allow access to the Datasette read or write JSON APIs, as those use different URL patterns within the Datasette `/database` hierarchy. This issue is patched in version 1.0a4.

Weakness: CWE-213

Which versions are affected by CVE-2023-40570?

3 open source packages ship an affected version, including datasette. It affects 1 product.

PackageAffectedFixed in
datasette PyPIAll versionsNone
datasette PyPIFrom 1.0a01.0a4
datasette PyPIFrom 1.0a01.0a4

Products include Datasette Datasette.

How do I fix CVE-2023-40570?

Upgrade datasette to 1.0a4 or later.

Is CVE-2023-40570 being exploited?

There is no known exploitation of CVE-2023-40570 in the wild and no public exploit code.

Sources

Also known as GHSA-7ch3-7pp7-7cpq, PYSEC-2023-154.

Is CVE-2023-40570 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free